[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <8dc33d99-4b50-fdb7-e81b-581939dadeaa@huaweicloud.com>
Date: Tue, 28 May 2024 21:32:40 +0800
From: Yu Kuai <yukuai1@...weicloud.com>
To: linan666@...weicloud.com, song@...nel.org
Cc: linux-raid@...r.kernel.org, linux-kernel@...r.kernel.org,
yi.zhang@...wei.com, houtao1@...wei.com, yangerkun@...wei.com,
"yukuai (C)" <yukuai3@...wei.com>
Subject: Re: [PATCH v2] md: make md_flush_request() more readable
Hi,
在 2024/05/29 4:31, linan666@...weicloud.com 写道:
> From: Li Nan <linan122@...wei.com>
>
> Setting bio to NULL and checking 'if(!bio)' is redundant and looks strange,
> just consolidate them into one condition. There are no functional changes.
>
> Suggested-by: Christoph Hellwig <hch@...radead.org>
> Signed-off-by: Li Nan <linan122@...wei.com>
> ---
> v2: Rewrite the code according to Christoph's suggestion.
>
> drivers/md/md.c | 28 +++++++++++++---------------
> 1 file changed, 13 insertions(+), 15 deletions(-)
>
> diff --git a/drivers/md/md.c b/drivers/md/md.c
> index aff9118ff697..9598b4898ea9 100644
> --- a/drivers/md/md.c
> +++ b/drivers/md/md.c
> @@ -654,24 +654,22 @@ bool md_flush_request(struct mddev *mddev, struct bio *bio)
> WARN_ON(percpu_ref_is_zero(&mddev->active_io));
> percpu_ref_get(&mddev->active_io);
> mddev->flush_bio = bio;
> - bio = NULL;
> - }
> - spin_unlock_irq(&mddev->lock);
> -
> - if (!bio) {
> + spin_unlock_irq(&mddev->lock);
> INIT_WORK(&mddev->flush_work, submit_flushes);
> queue_work(md_wq, &mddev->flush_work);
> - } else {
> - /* flush was performed for some other bio while we waited. */
> - if (bio->bi_iter.bi_size == 0)
> - /* an empty barrier - all done */
> - bio_endio(bio);
> - else {
> - bio->bi_opf &= ~REQ_PREFLUSH;
> - return false;
> - }
> + return true;
> }
> - return true;
> +
> + /* flush was performed for some other bio while we waited. */
> + spin_unlock_irq(&mddev->lock);
> + if (bio->bi_iter.bi_size == 0) {
It's better to use bio_sectors() here.
Thanks,
Kuai
> + /* pure flush without data - all done */
> + bio_endio(bio);
> + return true;
> + }
> +
> + bio->bi_opf &= ~REQ_PREFLUSH;
> + return false;
> }
> EXPORT_SYMBOL(md_flush_request);
>
>
Powered by blists - more mailing lists