lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date: Tue, 28 May 2024 22:00:21 -0400
From: Matthew Sakai <msakai@...hat.com>
To: Jiapeng Chong <jiapeng.chong@...ux.alibaba.com>
Cc: dm-devel@...ts.linux.dev, linux-kernel@...r.kernel.org,
 Abaci Robot <abaci@...ux.alibaba.com>, Mike Snitzer <snitzer@...nel.org>
Subject: Re: [PATCH] dm vdo indexer: Use swap() instead of open coding it

On 5/24/24 03:41, Jiapeng Chong wrote:
> Swap is a function interface that provides exchange function. To avoid
> code duplication, we can use swap function.
> 
> ./drivers/md/dm-vdo/indexer/index.c:207:43-44: WARNING opportunity for swap().
> 
> Reported-by: Abaci Robot <abaci@...ux.alibaba.com>
> Closes: https://bugzilla.openanolis.cn/show_bug.cgi?id=9173
> Signed-off-by: Jiapeng Chong <jiapeng.chong@...ux.alibaba.com>

Reviewed-by: Matthew Sakai <msakai@...hat.com>

Mike, can you make sure this gets applied with the rest of the pending 
dm patches?

> ---
>   drivers/md/dm-vdo/indexer/index.c | 5 +----
>   1 file changed, 1 insertion(+), 4 deletions(-)
> 
> diff --git a/drivers/md/dm-vdo/indexer/index.c b/drivers/md/dm-vdo/indexer/index.c
> index 1ba767144426..df4934846244 100644
> --- a/drivers/md/dm-vdo/indexer/index.c
> +++ b/drivers/md/dm-vdo/indexer/index.c
> @@ -197,15 +197,12 @@ static int finish_previous_chapter(struct uds_index *index, u64 current_chapter_
>   static int swap_open_chapter(struct index_zone *zone)
>   {
>   	int result;
> -	struct open_chapter_zone *temporary_chapter;
>   
>   	result = finish_previous_chapter(zone->index, zone->newest_virtual_chapter);
>   	if (result != UDS_SUCCESS)
>   		return result;
>   
> -	temporary_chapter = zone->open_chapter;
> -	zone->open_chapter = zone->writing_chapter;
> -	zone->writing_chapter = temporary_chapter;
> +	swap(zone->open_chapter, zone->writing_chapter);
>   	return UDS_SUCCESS;
>   }
>   


Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ