[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20240601213309.1262206-1-qyousef@layalina.io>
Date: Sat, 1 Jun 2024 22:33:07 +0100
From: Qais Yousef <qyousef@...alina.io>
To: Ingo Molnar <mingo@...nel.org>,
Peter Zijlstra <peterz@...radead.org>,
Juri Lelli <juri.lelli@...hat.com>,
Steven Rostedt <rostedt@...dmis.org>
Cc: Vincent Guittot <vincent.guittot@...aro.org>,
Daniel Bristot de Oliveira <bristot@...hat.com>,
Thomas Gleixner <tglx@...utronix.de>,
Sebastian Andrzej Siewior <bigeasy@...utronix.de>,
Alexander Viro <viro@...iv.linux.org.uk>,
Christian Brauner <brauner@...nel.org>,
Andrew Morton <akpm@...ux-foundation.org>,
Jens Axboe <axboe@...nel.dk>,
linux-kernel@...r.kernel.org,
linux-fsdevel@...r.kernel.org,
linux-trace-kernel@...r.kernel.org,
linux-mm@...ck.org,
Qais Yousef <qyousef@...alina.io>
Subject: [PATCH v4 0/2] Clean up usage of rt_task()
Make rt_task() return true only for RT class and add new realtime_task() to
return true for RT and DL classes to avoid some confusion the old API can
cause.
No functional changes intended in patch 1. Patch 2 cleans up the return type as
suggested by Steve.
Changes since v3:
* Make sure the 'new' bool functions return true/false instead of 1/0.
* Drop patch 2 about hrtimer usage of realtime_task() as ongoing
discussion on v1 indicates its scope outside of this simple cleanup.
Changes since v2:
* Fix one user that should use realtime_task() but remained using
rt_task() (Sebastian)
* New patch to convert all hrtimer users to use realtime_task_policy()
(Sebastian)
* Add a new patch to convert return type to bool (Steve)
* Rebase on tip/sched/core and handle a conflict with code shuffle to
syscalls.c
* Add Reviewed-by Steve
Changes since v1:
* Use realtime_task_policy() instead task_has_realtime_policy() (Peter)
* Improve commit message readability about replace some rt_task()
users.
v1 discussion: https://lore.kernel.org/lkml/20240514234112.792989-1-qyousef@layalina.io/
v2 discussion: https://lore.kernel.org/lkml/20240515220536.823145-1-qyousef@layalina.io/
v3 discussion: https://lore.kernel.org/lkml/20240527234508.1062360-1-qyousef@layalina.io/
Qais Yousef (2):
sched/rt: Clean up usage of rt_task()
sched/rt, dl: Convert functions to return bool
fs/bcachefs/six.c | 2 +-
fs/select.c | 2 +-
include/linux/ioprio.h | 2 +-
include/linux/sched/deadline.h | 14 +++++++------
include/linux/sched/prio.h | 1 +
include/linux/sched/rt.h | 35 ++++++++++++++++++++++++++-----
kernel/locking/rtmutex.c | 4 ++--
kernel/locking/rwsem.c | 4 ++--
kernel/locking/ww_mutex.h | 2 +-
kernel/sched/core.c | 4 ++--
kernel/sched/syscalls.c | 2 +-
kernel/time/hrtimer.c | 6 +++---
kernel/trace/trace_sched_wakeup.c | 2 +-
mm/page-writeback.c | 4 ++--
mm/page_alloc.c | 2 +-
15 files changed, 57 insertions(+), 29 deletions(-)
--
2.34.1
Powered by blists - more mailing lists