lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Mon, 3 Jun 2024 20:23:03 +0100
From: Jonathan Cameron <jic23@...nel.org>
To: Vasileios Amoiridis <vassilisamir@...il.com>
Cc: lars@...afoo.de, himanshujha199640@...il.com, linux-iio@...r.kernel.org,
 linux-kernel@...r.kernel.org
Subject: Re: [PATCH v1 04/17] iio: chemical: bme680: Fix sensor data read
 operation


> > > +}
> > > +
> > > +static void bme680_wait_for_eoc(struct bme680_data *data)  
> > Don't call it wait as that implies something is being checked.
> > 
> > bme680_conversion_sleep() or something like that.
> >   
> 
> This sesnor has a sleep mode, so I think calling a function like that might
> make it a bit confusing, since we are not putting the sensor into sleeping
> mode but rather actually wait for the eoc.

Hmm. Bikesheding time. I don't like wait because it generally implies a
condition check.

Maybe just go more explicit
bme680_suspend_execution_until_conversion_done()
bme680_suspend_execution_whilst_converting()
or similar might be overkill but something along those lines.

The suspend execution terminology lifted from man usleep

> 
> > > +{
> > > +	int wait_eoc = bme680_conversion_time_us(data->oversampling_temp +
> > > +						 data->oversampling_press +
> > > +						 data->oversampling_press,
> > > +						 data->heater_dur);  

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ