[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <87bk4imdu8.fsf@metaspace.dk>
Date: Mon, 03 Jun 2024 14:05:03 +0200
From: Andreas Hindborg <nmi@...aspace.dk>
To: Alice Ryhl <aliceryhl@...gle.com>
Cc: Hannes Reinecke <hare@...e.de>, Keith Busch <kbusch@...nel.org>, Jens
Axboe <axboe@...nel.dk>, Christoph Hellwig <hch@....de>, Damien Le Moal
<dlemoal@...nel.org>, Bart Van Assche <bvanassche@....org>, Ming Lei
<ming.lei@...hat.com>, "linux-block@...r.kernel.org"
<linux-block@...r.kernel.org>, Andreas Hindborg <a.hindborg@...sung.com>,
Greg KH <gregkh@...uxfoundation.org>, Matthew Wilcox
<willy@...radead.org>, Miguel Ojeda <ojeda@...nel.org>, Alex Gaynor
<alex.gaynor@...il.com>, Wedson Almeida Filho <wedsonaf@...il.com>,
Boqun Feng <boqun.feng@...il.com>, Gary Guo <gary@...yguo.net>,
Björn
Roy Baron <bjorn3_gh@...tonmail.com>, Benno Lossin
<benno.lossin@...ton.me>, Chaitanya Kulkarni <chaitanyak@...dia.com>,
Luis Chamberlain <mcgrof@...nel.org>, Yexuan Yang
<1182282462@...t.edu.cn>, Sergio González Collado
<sergio.collado@...il.com>, Joel Granados <j.granados@...sung.com>,
"Pankaj Raghav (Samsung)" <kernel@...kajraghav.com>, Daniel Gomez
<da.gomez@...sung.com>, Niklas Cassel <Niklas.Cassel@....com>, Philipp
Stanner <pstanner@...hat.com>, Conor Dooley <conor@...nel.org>, Johannes
Thumshirn <Johannes.Thumshirn@....com>, Matias Bjørling
<m@...rling.me>,
open list <linux-kernel@...r.kernel.org>,
"rust-for-linux@...r.kernel.org" <rust-for-linux@...r.kernel.org>,
"lsf-pc@...ts.linux-foundation.org" <lsf-pc@...ts.linux-foundation.org>,
"gost.dev@...sung.com" <gost.dev@...sung.com>
Subject: Re: [PATCH v4 2/3] rust: block: add rnull, Rust null_blk
implementation
Alice Ryhl <aliceryhl@...gle.com> writes:
> On Mon, Jun 3, 2024 at 11:05 AM Hannes Reinecke <hare@...e.de> wrote:
>>
>> On 6/1/24 18:01, Keith Busch wrote:
>> > On Sat, Jun 01, 2024 at 05:36:20PM +0200, Andreas Hindborg wrote:
>> >> Keith Busch <kbusch@...nel.org> writes:
>> >>
>> >>> On Sat, Jun 01, 2024 at 03:40:04PM +0200, Andreas Hindborg wrote:
>> >>>> +impl kernel::Module for NullBlkModule {
>> >>>> + fn init(_module: &'static ThisModule) -> Result<Self> {
>> >>>> + pr_info!("Rust null_blk loaded\n");
>> >>>> + let tagset = Arc::pin_init(TagSet::try_new(1, 256, 1), flags::GFP_KERNEL)?;
>> >>>> +
>> >>>> + let disk = {
>> >>>> + let block_size: u16 = 4096;
>> >>>> + if block_size % 512 != 0 || !(512..=4096).contains(&block_size) {
>> >>>> + return Err(kernel::error::code::EINVAL);
>> >>>> + }
>> >>>
>> >>> You've set block_size to the literal 4096, then validate its value
>> >>> immediately after? Am I missing some way this could ever be invalid?
>> >>
>> >> Good catch. It is because I have a patch in the outbound queue that allows setting
>> >> the block size via a module parameter. The module parameter patch is not
>> >> upstream yet. Once I have that up, I will send the patch with the block
>> >> size config.
>> >>
>> >> Do you think it is OK to have this redundancy? It would only be for a
>> >> few cycles.
>> >
>> > It's fine, just wondering why it's there. But it also allows values like
>> > 1536 and 3584, which are not valid block sizes, so I think you want the
>> > check to be:
>> >
>> > if !(512..=4096).contains(&block_size) || ((block_size & (block_size - 1)) != 0)
>> >
>> Can't we overload .contains() to check only power-of-2 values?
>
> Rust integers have a method called is_power_of_two. If you need to
> assert that it's a power of two, you can use that.
Thanks Alice, that is much easier to read 👍
BR Andreas
Powered by blists - more mailing lists