lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Tue, 4 Jun 2024 14:29:10 +0100
From: Qais Yousef <qyousef@...alina.io>
To: John Stultz <jstultz@...gle.com>
Cc: LKML <linux-kernel@...r.kernel.org>, Joel Fernandes <joelaf@...gle.com>,
	Ingo Molnar <mingo@...hat.com>,
	Peter Zijlstra <peterz@...radead.org>,
	Juri Lelli <juri.lelli@...hat.com>,
	Vincent Guittot <vincent.guittot@...aro.org>,
	Dietmar Eggemann <dietmar.eggemann@....com>,
	Valentin Schneider <vschneid@...hat.com>,
	Steven Rostedt <rostedt@...dmis.org>,
	Ben Segall <bsegall@...gle.com>,
	Zimuzo Ezeozue <zezeozue@...gle.com>,
	Youssef Esmat <youssefesmat@...gle.com>,
	Mel Gorman <mgorman@...e.de>,
	Daniel Bristot de Oliveira <bristot@...hat.com>,
	Will Deacon <will@...nel.org>, Waiman Long <longman@...hat.com>,
	Boqun Feng <boqun.feng@...il.com>,
	"Paul E. McKenney" <paulmck@...nel.org>,
	Metin Kaya <Metin.Kaya@....com>,
	Xuewen Yan <xuewen.yan94@...il.com>,
	K Prateek Nayak <kprateek.nayak@....com>,
	Thomas Gleixner <tglx@...utronix.de>, kernel-team@...roid.com
Subject: Re: [PATCH v10 6/7] sched: Split out __schedule() deactivate task
 logic into a helper

On 05/06/24 21:54, John Stultz wrote:
> As we're going to re-use the deactivation logic,
> split it into a helper.
> 
> Cc: Joel Fernandes <joelaf@...gle.com>
> Cc: Qais Yousef <qyousef@...alina.io>
> Cc: Ingo Molnar <mingo@...hat.com>
> Cc: Peter Zijlstra <peterz@...radead.org>
> Cc: Juri Lelli <juri.lelli@...hat.com>
> Cc: Vincent Guittot <vincent.guittot@...aro.org>
> Cc: Dietmar Eggemann <dietmar.eggemann@....com>
> Cc: Valentin Schneider <vschneid@...hat.com>
> Cc: Steven Rostedt <rostedt@...dmis.org>
> Cc: Ben Segall <bsegall@...gle.com>
> Cc: Zimuzo Ezeozue <zezeozue@...gle.com>
> Cc: Youssef Esmat <youssefesmat@...gle.com>
> Cc: Mel Gorman <mgorman@...e.de>
> Cc: Daniel Bristot de Oliveira <bristot@...hat.com>
> Cc: Will Deacon <will@...nel.org>
> Cc: Waiman Long <longman@...hat.com>
> Cc: Boqun Feng <boqun.feng@...il.com>
> Cc: "Paul E. McKenney" <paulmck@...nel.org>
> Cc: Metin Kaya <Metin.Kaya@....com>
> Cc: Xuewen Yan <xuewen.yan94@...il.com>
> Cc: K Prateek Nayak <kprateek.nayak@....com>
> Cc: Thomas Gleixner <tglx@...utronix.de>
> Cc: kernel-team@...roid.com
> Tested-by: K Prateek Nayak <kprateek.nayak@....com>
> Tested-by: Metin Kaya <metin.kaya@....com>
> Reviewed-by: Metin Kaya <metin.kaya@....com>
> Signed-off-by: John Stultz <jstultz@...gle.com>
> ---
> v6:
> * Define function as static to avoid "no previous prototype"
>   warnings as Reported-by: kernel test robot <lkp@...el.com>
> v7:
> * Rename state task_state to be more clear, as suggested by
>   Metin Kaya
> ---
>  kernel/sched/core.c | 72 +++++++++++++++++++++++++++------------------
>  1 file changed, 43 insertions(+), 29 deletions(-)
> 
> diff --git a/kernel/sched/core.c b/kernel/sched/core.c
> index 48f0d4b381d5..8bc5844ebab9 100644
> --- a/kernel/sched/core.c
> +++ b/kernel/sched/core.c
> @@ -6572,6 +6572,48 @@ pick_next_task(struct rq *rq, struct task_struct *prev, struct rq_flags *rf)
>  # define SM_MASK_PREEMPT	SM_PREEMPT
>  #endif
>  
> +/*
> + * Helper function for __schedule()
> + *
> + * If a task does not have signals pending, deactivate it and return true
> + * Otherwise marks the task's __state as RUNNING and returns false
> + */
> +static bool try_to_deactivate_task(struct rq *rq, struct task_struct *p,
> +				   unsigned long task_state)
> +{
> +	if (signal_pending_state(task_state, p)) {
> +		WRITE_ONCE(p->__state, TASK_RUNNING);

We can avoid extra indention for the other (lengthy) leg if we return here?

The return value is ignored for now, I don't mind keeping it but better call it
out in the commit message or when you add the new user later you can update the
signature more easily.

Generally I think patches 4, 5 and 6 could be sent as their own series with
minor commit messages tweaks to make them more independent and I hope Ingo and
Peter are okay to pick them up as they look a nice clean up in general.

Anyway:

Reviewed-by: Qais Yousef <qyousef@...alina.io>

> +	} else {
> +		p->sched_contributes_to_load =
> +			(task_state & TASK_UNINTERRUPTIBLE) &&
> +			!(task_state & TASK_NOLOAD) &&
> +			!(task_state & TASK_FROZEN);
> +
> +		if (p->sched_contributes_to_load)
> +			rq->nr_uninterruptible++;
> +
> +		/*
> +		 * __schedule()			ttwu()
> +		 *   prev_state = prev->state;    if (p->on_rq && ...)
> +		 *   if (prev_state)		    goto out;
> +		 *     p->on_rq = 0;		  smp_acquire__after_ctrl_dep();
> +		 *				  p->state = TASK_WAKING
> +		 *
> +		 * Where __schedule() and ttwu() have matching control dependencies.
> +		 *
> +		 * After this, schedule() must not care about p->state any more.
> +		 */
> +		deactivate_task(rq, p, DEQUEUE_SLEEP | DEQUEUE_NOCLOCK);
> +
> +		if (p->in_iowait) {
> +			atomic_inc(&rq->nr_iowait);
> +			delayacct_blkio_start();
> +		}
> +		return true;
> +	}
> +	return false;
> +}
> +
>  /*
>   * __schedule() is the main scheduler function.
>   *
> @@ -6665,35 +6707,7 @@ static void __sched notrace __schedule(unsigned int sched_mode)
>  	 */
>  	prev_state = READ_ONCE(prev->__state);
>  	if (!(sched_mode & SM_MASK_PREEMPT) && prev_state) {
> -		if (signal_pending_state(prev_state, prev)) {
> -			WRITE_ONCE(prev->__state, TASK_RUNNING);
> -		} else {
> -			prev->sched_contributes_to_load =
> -				(prev_state & TASK_UNINTERRUPTIBLE) &&
> -				!(prev_state & TASK_NOLOAD) &&
> -				!(prev_state & TASK_FROZEN);
> -
> -			if (prev->sched_contributes_to_load)
> -				rq->nr_uninterruptible++;
> -
> -			/*
> -			 * __schedule()			ttwu()
> -			 *   prev_state = prev->state;    if (p->on_rq && ...)
> -			 *   if (prev_state)		    goto out;
> -			 *     p->on_rq = 0;		  smp_acquire__after_ctrl_dep();
> -			 *				  p->state = TASK_WAKING
> -			 *
> -			 * Where __schedule() and ttwu() have matching control dependencies.
> -			 *
> -			 * After this, schedule() must not care about p->state any more.
> -			 */
> -			deactivate_task(rq, prev, DEQUEUE_SLEEP | DEQUEUE_NOCLOCK);
> -
> -			if (prev->in_iowait) {
> -				atomic_inc(&rq->nr_iowait);
> -				delayacct_blkio_start();
> -			}
> -		}
> +		try_to_deactivate_task(rq, prev, prev_state);
>  		switch_count = &prev->nvcsw;
>  	}
>  
> -- 
> 2.45.0.rc1.225.g2a3ae87e7f-goog
> 

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ