[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-Id: <20240608233242.414564f51bcc5db9993eb682@kernel.org>
Date: Sat, 8 Jun 2024 23:32:42 +0900
From: Masami Hiramatsu (Google) <mhiramat@...nel.org>
To: Steven Rostedt <rostedt@...dmis.org>
Cc: LKML <linux-kernel@...r.kernel.org>, Linux Trace Kernel
<linux-trace-kernel@...r.kernel.org>, Masami Hiramatsu
<mhiramat@...nel.org>, Mark Rutland <mark.rutland@....com>, Mathieu
Desnoyers <mathieu.desnoyers@...icios.com>
Subject: Re: [PATCH] function_graph: Rename BYTE_NUMBER to CHAR_NUMBER in
selftests
On Thu, 6 Jun 2024 08:18:46 -0400
Steven Rostedt <rostedt@...dmis.org> wrote:
> From: "Steven Rostedt (Google)" <rostedt@...dmis.org>
>
> The function_graph selftests checks various size variables to pass from
> the entry of the function to the exit. It tests 1, 2, 4 and 8 byte words.
> The 1 byte macro was called BYTE_NUMBER but that is used in the sh
> architecture: arch/sh/include/asm/bitops-op32.h
>
> Just rename the macro to CHAR_NUMBER.
>
Looks good to me.
Acked-by: Masami Hiramatsu (Google) <mhiramat@...nel.org>
Thanks,
> Fixes: 47c3c70aa3697 ("function_graph: Add selftest for passing local variables")
> Reported-by: kernel test robot <lkp@...el.com>
> Closes: https://lore.kernel.org/oe-kbuild-all/202406061744.rZDXfRrG-lkp@intel.com/
> Signed-off-by: Steven Rostedt (Google) <rostedt@...dmis.org>
> ---
> kernel/trace/trace_selftest.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/kernel/trace/trace_selftest.c b/kernel/trace/trace_selftest.c
> index 369efc569238..adf0f436d84b 100644
> --- a/kernel/trace/trace_selftest.c
> +++ b/kernel/trace/trace_selftest.c
> @@ -758,7 +758,7 @@ trace_selftest_startup_function(struct tracer *trace, struct trace_array *tr)
>
> #ifdef CONFIG_DYNAMIC_FTRACE
>
> -#define BYTE_NUMBER 123
> +#define CHAR_NUMBER 123
> #define SHORT_NUMBER 12345
> #define WORD_NUMBER 1234567890
> #define LONG_NUMBER 1234567890123456789LL
> @@ -789,7 +789,7 @@ static __init int store_entry(struct ftrace_graph_ent *trace,
>
> switch (size) {
> case 1:
> - *(char *)p = BYTE_NUMBER;
> + *(char *)p = CHAR_NUMBER;
> break;
> case 2:
> *(short *)p = SHORT_NUMBER;
> @@ -830,7 +830,7 @@ static __init void store_return(struct ftrace_graph_ret *trace,
>
> switch (fixture->store_size) {
> case 1:
> - expect = BYTE_NUMBER;
> + expect = CHAR_NUMBER;
> found = *(char *)p;
> break;
> case 2:
> --
> 2.43.0
>
>
--
Masami Hiramatsu (Google) <mhiramat@...nel.org>
Powered by blists - more mailing lists