[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <ZmQAZ-REghlJmax-@gmail.com>
Date: Sat, 8 Jun 2024 08:55:35 +0200
From: Ingo Molnar <mingo@...nel.org>
To: Oleg Nesterov <oleg@...hat.com>
Cc: linux-kernel@...r.kernel.org, Andy Lutomirski <luto@...capital.net>,
Andrew Morton <akpm@...ux-foundation.org>,
Dave Hansen <dave@...1.net>, Peter Zijlstra <peterz@...radead.org>,
Borislav Petkov <bp@...en8.de>, "H . Peter Anvin" <hpa@...or.com>,
Linus Torvalds <torvalds@...ux-foundation.org>,
Thomas Gleixner <tglx@...utronix.de>,
Uros Bizjak <ubizjak@...il.com>
Subject: Re: [PATCH 2/3] x86/fpu: Remove the thread::fpu pointer
* Ingo Molnar <mingo@...nel.org> wrote:
>
> * Oleg Nesterov <oleg@...hat.com> wrote:
>
> > On 06/05, Ingo Molnar wrote:
> > >
> > > @@ -591,13 +591,11 @@ int fpu_clone(struct task_struct *dst, unsigned long clone_flags, bool minimal,
> > > * This is safe because task_struct size is a multiple of cacheline size.
> > > */
> > > struct fpu *dst_fpu = (void *)dst + sizeof(*dst);
> > > - struct fpu *src_fpu = current->thread.fpu;
> > > + struct fpu *src_fpu = x86_task_fpu(current);
> >
> > I think this patch can also change
> >
> > struct fpu *dst_fpu = (void *)dst + sizeof(*dst);
> >
> > above to use x86_task_fpu(dst).
>
> Yeah, so I'd prefer to keep it open coded, because of the comment and the
> debug check makes a lot more sense if the pointer calculation is visible:
On a second thought I changed it to your suggested variant:
struct fpu *src_fpu = x86_task_fpu(current);
struct fpu *dst_fpu = x86_task_fpu(dst);
because you are right, it's in fact easier to read this way.
Thanks,
Ingo
Powered by blists - more mailing lists