[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-id: <171817613375.14261.11854641862108370837@noble.neil.brown.name>
Date: Wed, 12 Jun 2024 17:08:53 +1000
From: "NeilBrown" <neilb@...e.de>
To: "Al Viro" <viro@...iv.linux.org.uk>
Cc: "Christian Brauner" <brauner@...nel.org>, "Jan Kara" <jack@...e.cz>,
"Amir Goldstein" <amir73il@...il.com>, "James Clark" <james.clark@....com>,
ltp@...ts.linux.it, linux-nfs@...r.kernel.org,
"LKML" <linux-kernel@...r.kernel.org>, linux-fsdevel@...r.kernel.org
Subject:
Re: [PATCH] VFS: generate FS_CREATE before FS_OPEN when ->atomic_open used.
On Wed, 12 Jun 2024, Al Viro wrote:
> On Wed, Jun 12, 2024 at 12:55:40PM +1000, NeilBrown wrote:
> > > IF we don't care about that, we might as well take fsnotify_open()
> > > out of vfs_open() and, for do_open()/do_tmpfile()/do_o_path(), into
> > > path_openat() itself. I mean, having
> > > if (likely(!error)) {
> > > if (likely(file->f_mode & FMODE_OPENED)) {
> > > fsnotify_open(file);
> > > return file;
> > > }
> > > in there would be a lot easier to follow... It would lose fsnotify_open()
> > > in a few more failure exits, but if we don't give a damn about having it
> > > paired with fsnotify_close()...
> > >
> >
> > Should we have fsnotify_open() set a new ->f_mode flag, and
> > fsnotify_close() abort if it isn't set (and clear it if it is)?
> > Then we would be guaranteed a balance - which does seem like a good
> > idea.
>
> Umm... In that case, I would rather have FMODE_NONOTIFY set just before
> the fput() in path_openat() - no need to grab another flag from ->f_mode
> (not a lot of unused ones there) and no need to add any overhead on
> the fast path.
>
Unfortunately that gets messy if handle_truncate() fails. We would need
to delay the fsnotify_open() until after truncate which means moving it
out of vfs_open() or maybe calling do_dentry_open() directly from
do_open() - neither of which I like.
I think it is best to stick with "if FMODE_OPENED is set, then we call
fsnotify_open() even if the open will fail", and only move the place
where fsnotify_open() is called.
BTW I was wrong about gfs. Closer inspection of the code show that
finish_open() is only called in the ->atomic_open case.
Thanks,
NeilBrown
Powered by blists - more mailing lists