[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <0bb414fa-851b-40cf-ede9-fc6252c6b173@linux.intel.com>
Date: Wed, 12 Jun 2024 10:38:08 +0300 (EEST)
From: Ilpo Järvinen <ilpo.jarvinen@...ux.intel.com>
To: Douglas Anderson <dianders@...omium.org>
cc: Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
Jiri Slaby <jirislaby@...nel.org>, Yicong Yang <yangyicong@...ilicon.com>,
Tony Lindgren <tony@...mide.com>,
Andy Shevchenko <andriy.shevchenko@...ux.intel.com>,
Johan Hovold <johan+linaro@...nel.org>,
John Ogness <john.ogness@...utronix.de>, linux-arm-msm@...r.kernel.org,
Bjorn Andersson <andersson@...nel.org>,
Konrad Dybcio <konrad.dybcio@...aro.org>,
Stephen Boyd <swboyd@...omium.org>,
linux-serial <linux-serial@...r.kernel.org>,
LKML <linux-kernel@...r.kernel.org>,
Uwe Kleine-König <u.kleine-koenig@...gutronix.de>
Subject: Re: [PATCH v4 2/8] tty: serial: Add uart_fifo_timeout_ms()
On Mon, 10 Jun 2024, Douglas Anderson wrote:
> The current uart_fifo_timeout() returns jiffies, which is not always
> the most convenient for callers. Add a variant uart_fifo_timeout_ms()
> that returns the timeout in milliseconds.
>
> NOTES:
> - msecs_to_jiffies() rounds up, unlike nsecs_to_jiffies(). This is
> because msecs_to_jiffies() is actually intended for device drivers
> to calculate timeout value. This means we don't need to take the max
> of the timeout and "1" since the timeout will always be > 0 ms (we
> add 20 ms of slop).
> - uart_fifo_timeout_ms() returns "unsigned int" but we leave
> uart_fifo_timeout() returning "unsigned long". This matches the
> types of msecs_to_jiffies().
>
> Suggested-by: Ilpo Järvinen <ilpo.jarvinen@...ux.intel.com>
> Signed-off-by: Douglas Anderson <dianders@...omium.org>
> ---
>
> Changes in v4:
> - New
>
> include/linux/serial_core.h | 15 +++++++++++----
> 1 file changed, 11 insertions(+), 4 deletions(-)
>
> diff --git a/include/linux/serial_core.h b/include/linux/serial_core.h
> index 8cb65f50e830..97968acfd564 100644
> --- a/include/linux/serial_core.h
> +++ b/include/linux/serial_core.h
> @@ -889,14 +889,21 @@ unsigned int uart_get_divisor(struct uart_port *port, unsigned int baud);
> /*
> * Calculates FIFO drain time.
> */
> -static inline unsigned long uart_fifo_timeout(struct uart_port *port)
> +static inline unsigned int uart_fifo_timeout_ms(struct uart_port *port)
> {
> u64 fifo_timeout = (u64)READ_ONCE(port->frame_time) * port->fifosize;
> + unsigned int fifo_timeout_ms = div_u64(fifo_timeout, NSEC_PER_MSEC);
>
> - /* Add .02 seconds of slop */
> - fifo_timeout += 20 * NSEC_PER_MSEC;
> + /*
> + * Add .02 seconds of slop. This also helps account for the fact that
> + * when we converted from ns to ms that we didn't round up.
> + */
> + return fifo_timeout_ms + 20;
> +}
>
> - return max(nsecs_to_jiffies(fifo_timeout), 1UL);
> +static inline unsigned long uart_fifo_timeout(struct uart_port *port)
> +{
> + return msecs_to_jiffies(uart_fifo_timeout_ms(port));
> }
Hi,
This is definitely towards the right direction! However, it now does
double conversion, first div_u64() and then msecs_to_jiffies(). Perhaps it
would be better to retain the nsecs version (maybe rename it to _ns for
consistency) and add _ms variant that does the nsec -> msec conversion.
--
i.
Powered by blists - more mailing lists