[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <7a9eddb2-2ad1-4aab-8edb-548f05b524ec@suse.com>
Date: Tue, 18 Jun 2024 14:45:37 +0300
From: Nikolay Borisov <nik.borisov@...e.com>
To: Kai Huang <kai.huang@...el.com>, linux-kernel@...r.kernel.org
Cc: x86@...nel.org, dave.hansen@...el.com, dan.j.williams@...el.com,
kirill.shutemov@...ux.intel.com, rick.p.edgecombe@...el.com,
peterz@...radead.org, tglx@...utronix.de, bp@...en8.de, mingo@...hat.com,
hpa@...or.com, seanjc@...gle.com, pbonzini@...hat.com, kvm@...r.kernel.org,
isaku.yamahata@...el.com, binbin.wu@...ux.intel.com
Subject: Re: [PATCH 4/9] x86/virt/tdx: Abstract reading multiple global
metadata fields as a helper
On 16.06.24 г. 15:01 ч., Kai Huang wrote:
> For now the kernel only reads "TD Memory Region" (TDMR) related global
> metadata fields to a 'struct tdx_tdmr_sysinfo' for initializing the TDX
> module. Future changes will need to read other metadata fields that
> don't make sense to populate to the "struct tdx_tdmr_sysinfo".
>
> Now the code in get_tdx_tdmr_sysinfo() to read multiple global metadata
> fields is not bound to the 'struct tdx_tdmr_sysinfo', and can support
> reading all metadata element sizes. Abstract this code as a helper for
> future use.
>
> Signed-off-by: Kai Huang <kai.huang@...el.com>
> ---
> arch/x86/virt/vmx/tdx/tdx.c | 27 ++++++++++++++++-----------
> 1 file changed, 16 insertions(+), 11 deletions(-)
>
> diff --git a/arch/x86/virt/vmx/tdx/tdx.c b/arch/x86/virt/vmx/tdx/tdx.c
> index 4392e82a9bcb..c68fbaf4aa15 100644
> --- a/arch/x86/virt/vmx/tdx/tdx.c
> +++ b/arch/x86/virt/vmx/tdx/tdx.c
> @@ -304,6 +304,21 @@ struct field_mapping {
> .offset = offsetof(_struct, _member), \
> .size = sizeof(typeof(((_struct *)0)->_member)) }
>
> +static int stbuf_read_sysmd_multi(const struct field_mapping *fields,
Rename it to read_system_metadata_fields i.e just use the plural form of
the single field function. Whatever you choose to rename the singular
form, just make this function be the plural. But as a general remark - I
don't see what value the "stbuf" prefix brings. 'sysmd' is also somewhat
unintuitive. Any of
read_metadata_fields/read_sys_metadata_fields/read_system_metadata_fields
seem better.
> + int nr_fields, void *stbuf)
> +{
> + int i, ret;
> +
> + for (i = 0; i < nr_fields; i++) {
> + ret = stbuf_read_sysmd_field(fields[i].field_id, stbuf,
> + fields[i].offset, fields[i].size);
> + if (ret)
> + return ret;
> + }
> +
> + return 0;
> +}
> +
> #define TD_SYSINFO_MAP_TDMR_INFO(_field_id, _member) \
> TD_SYSINFO_MAP(_field_id, struct tdx_tdmr_sysinfo, _member)
>
<snip>
Powered by blists - more mailing lists