lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Fri, 21 Jun 2024 08:08:01 -0700
From: Guenter Roeck <linux@...ck-us.net>
To: Sean Anderson <sean.anderson@...ux.dev>,
 Jonathan Cameron <jic23@...nel.org>, Jean Delvare <jdelvare@...e.com>,
 linux-iio@...r.kernel.org, linux-hwmon@...r.kernel.org
Cc: Lars-Peter Clausen <lars@...afoo.de>, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 2/2] hwmon: iio: Add labels from IIO channels

On 6/20/24 14:13, Sean Anderson wrote:
> Add labels from IIO channels to our channels. This allows userspace to
> display more meaningful names instead of "in0" or "temp5".
> 
> Signed-off-by: Sean Anderson <sean.anderson@...ux.dev>
> ---
> 
>   drivers/hwmon/iio_hwmon.c | 33 ++++++++++++++++++++++++++++++---
>   1 file changed, 30 insertions(+), 3 deletions(-)
> 
> diff --git a/drivers/hwmon/iio_hwmon.c b/drivers/hwmon/iio_hwmon.c
> index 4c8a80847891..588b64c18e63 100644
> --- a/drivers/hwmon/iio_hwmon.c
> +++ b/drivers/hwmon/iio_hwmon.c
> @@ -33,6 +33,17 @@ struct iio_hwmon_state {
>   	struct attribute **attrs;
>   };
>   
> +static ssize_t iio_hwmon_read_label(struct device *dev,
> +				  struct device_attribute *attr,
> +				  char *buf)
> +{
> +	struct sensor_device_attribute *sattr = to_sensor_dev_attr(attr);
> +	struct iio_hwmon_state *state = dev_get_drvdata(dev);
> +	struct iio_channel *chan = &state->channels[sattr->index];
> +
> +	return iio_read_channel_label(chan, buf);

This can return -EINVAL if there is no label. Since the label attribute
is created unconditionally, every affected system would end up with
lots of error messages when running the "sensors" command.
This is not acceptable.

Guenter

> +}
> +
>   /*
>    * Assumes that IIO and hwmon operate in the same base units.
>    * This is supposed to be true, but needs verification for
> @@ -90,12 +101,12 @@ static int iio_hwmon_probe(struct platform_device *pdev)
>   
>   	st->channels = channels;
>   
> -	/* count how many attributes we have */
> +	/* count how many channels we have */
>   	while (st->channels[st->num_channels].indio_dev)
>   		st->num_channels++;
>   
>   	st->attrs = devm_kcalloc(dev,
> -				 st->num_channels + 1, sizeof(*st->attrs),
> +				 2 * st->num_channels + 1, sizeof(*st->attrs),
>   				 GFP_KERNEL);
>   	if (st->attrs == NULL)
>   		return -ENOMEM;
> @@ -147,7 +158,23 @@ static int iio_hwmon_probe(struct platform_device *pdev)
>   		a->dev_attr.show = iio_hwmon_read_val;
>   		a->dev_attr.attr.mode = 0444;
>   		a->index = i;
> -		st->attrs[i] = &a->dev_attr.attr;
> +		st->attrs[2 * i] = &a->dev_attr.attr;
> +
> +		a = devm_kzalloc(dev, sizeof(*a), GFP_KERNEL);
> +		if (a == NULL)
> +			return -ENOMEM;
> +
> +		sysfs_attr_init(&a->dev_attr.attr);
> +		a->dev_attr.attr.name = devm_kasprintf(dev, GFP_KERNEL,
> +						       "%s%d_label",
> +						       prefix, n);
> +		if (!a->dev_attr.attr.name)
> +			return -ENOMEM;
> +
> +		a->dev_attr.show = iio_hwmon_read_label;
> +		a->dev_attr.attr.mode = 0444;
> +		a->index = i;
> +		st->attrs[2 * i + 1] = &a->dev_attr.attr;
>   	}
>   
>   	st->attr_group.attrs = st->attrs;


Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ