lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Sun, 23 Jun 2024 07:17:09 +0000
From: Keith Zhao <keith.zhao@...rfivetech.com>
To: Dmitry Baryshkov <dmitry.baryshkov@...aro.org>
CC: "andrzej.hajda@...el.com" <andrzej.hajda@...el.com>,
	"neil.armstrong@...aro.org" <neil.armstrong@...aro.org>, "rfoss@...nel.org"
	<rfoss@...nel.org>, "Laurent.pinchart@...asonboard.com"
	<Laurent.pinchart@...asonboard.com>, "jonas@...boo.se" <jonas@...boo.se>,
	"jernej.skrabec@...il.com" <jernej.skrabec@...il.com>,
	"maarten.lankhorst@...ux.intel.com" <maarten.lankhorst@...ux.intel.com>,
	"mripard@...nel.org" <mripard@...nel.org>, "tzimmermann@...e.de"
	<tzimmermann@...e.de>, "airlied@...il.com" <airlied@...il.com>,
	"daniel@...ll.ch" <daniel@...ll.ch>, "robh@...nel.org" <robh@...nel.org>,
	"krzk+dt@...nel.org" <krzk+dt@...nel.org>, "conor+dt@...nel.org"
	<conor+dt@...nel.org>, "hjc@...k-chips.com" <hjc@...k-chips.com>,
	"heiko@...ech.de" <heiko@...ech.de>, "andy.yan@...k-chips.com"
	<andy.yan@...k-chips.com>, Xingyu Wu <xingyu.wu@...rfivetech.com>,
	"p.zabel@...gutronix.de" <p.zabel@...gutronix.de>, Jack Zhu
	<jack.zhu@...rfivetech.com>, Shengyang Chen
	<shengyang.chen@...rfivetech.com>, "dri-devel@...ts.freedesktop.org"
	<dri-devel@...ts.freedesktop.org>, "devicetree@...r.kernel.org"
	<devicetree@...r.kernel.org>, "linux-kernel@...r.kernel.org"
	<linux-kernel@...r.kernel.org>, "linux-arm-kernel@...ts.infradead.org"
	<linux-arm-kernel@...ts.infradead.org>
Subject: RE: [PATCH v4 10/10] drm/vs: add simple dsi encoder

Hi Dmitry:

> -----Original Message-----
> From: Dmitry Baryshkov <dmitry.baryshkov@...aro.org>
> Sent: 2024年5月21日 23:25
> To: Keith Zhao <keith.zhao@...rfivetech.com>
> Cc: andrzej.hajda@...el.com; neil.armstrong@...aro.org; rfoss@...nel.org;
> Laurent.pinchart@...asonboard.com; jonas@...boo.se;
> jernej.skrabec@...il.com; maarten.lankhorst@...ux.intel.com;
> mripard@...nel.org; tzimmermann@...e.de; airlied@...il.com;
> daniel@...ll.ch; robh@...nel.org; krzk+dt@...nel.org; conor+dt@...nel.org;
> hjc@...k-chips.com; heiko@...ech.de; andy.yan@...k-chips.com; Xingyu Wu
> <xingyu.wu@...rfivetech.com>; p.zabel@...gutronix.de; Jack Zhu
> <jack.zhu@...rfivetech.com>; Shengyang Chen
> <shengyang.chen@...rfivetech.com>; dri-devel@...ts.freedesktop.org;
> devicetree@...r.kernel.org; linux-kernel@...r.kernel.org;
> linux-arm-kernel@...ts.infradead.org
> Subject: Re: [PATCH v4 10/10] drm/vs: add simple dsi encoder
> 
> On Tue, May 21, 2024 at 06:58:17PM +0800, keith wrote:
> > add encoder to match cdns dsi driver
> >
> > Signed-off-by: keith <keith.zhao@...rfivetech.com>
> 
> Please fix your git configuration to include your full name into the S-o-B and
> Author fields.
Ok ,will fix it
> 
> > ---
> >  drivers/gpu/drm/verisilicon/Makefile        |   3 +-
> >  drivers/gpu/drm/verisilicon/vs_drv.c        |   1 +
> >  drivers/gpu/drm/verisilicon/vs_drv.h        |   1 +
> >  drivers/gpu/drm/verisilicon/vs_simple_enc.c | 190
> > ++++++++++++++++++++  drivers/gpu/drm/verisilicon/vs_simple_enc.h |
> > 25 +++
> >  5 files changed, 219 insertions(+), 1 deletion(-)  create mode 100644
> > drivers/gpu/drm/verisilicon/vs_simple_enc.c
> >  create mode 100644 drivers/gpu/drm/verisilicon/vs_simple_enc.h
> >
> > diff --git a/drivers/gpu/drm/verisilicon/Makefile
> > b/drivers/gpu/drm/verisilicon/Makefile
> > index 2d02b4a3a567..c35ba9bd6f81 100644
> > --- a/drivers/gpu/drm/verisilicon/Makefile
> > +++ b/drivers/gpu/drm/verisilicon/Makefile
> > @@ -4,7 +4,8 @@ vs_drm-objs := vs_dc_hw.o \
> >  		vs_modeset.o \
> >  		vs_plane.o \
> >  		vs_crtc.o \
> > -		vs_drv.o
> > +		vs_drv.o \
> > +		vs_simple_enc.o
> >
> >  vs_drm-$(CONFIG_DRM_INNO_STARFIVE_HDMI) += inno_hdmi-starfive.o
> >  obj-$(CONFIG_DRM_VERISILICON_DC8200) += vs_drm.o diff --git
> > a/drivers/gpu/drm/verisilicon/vs_drv.c
> > b/drivers/gpu/drm/verisilicon/vs_drv.c
> > index 6f04102b05b3..2748d48f2c7e 100644
> > --- a/drivers/gpu/drm/verisilicon/vs_drv.c
> > +++ b/drivers/gpu/drm/verisilicon/vs_drv.c
> > @@ -612,6 +612,7 @@ static struct platform_driver *drm_sub_drivers[] =
> > {  #ifdef CONFIG_DRM_INNO_STARFIVE_HDMI
> >  	&starfive_hdmi_driver,
> >  #endif
> > +	&simple_encoder_driver,
> >  };
> >
> >  static struct component_match *vs_add_external_components(struct
> > device *dev) diff --git a/drivers/gpu/drm/verisilicon/vs_drv.h
> > b/drivers/gpu/drm/verisilicon/vs_drv.h
> > index c3c08ed5f8ac..f3f0f170777d 100644
> > --- a/drivers/gpu/drm/verisilicon/vs_drv.h
> > +++ b/drivers/gpu/drm/verisilicon/vs_drv.h
> > @@ -17,6 +17,7 @@
> >  #include <drm/drm_managed.h>
> >
> >  #include "vs_dc_hw.h"
> > +#include "vs_simple_enc.h"
> >
> >  /*@...ch_alignment: buffer pitch alignment required by sub-devices.*/
> > struct vs_drm_device { diff --git
> > a/drivers/gpu/drm/verisilicon/vs_simple_enc.c
> > b/drivers/gpu/drm/verisilicon/vs_simple_enc.c
> > new file mode 100644
> > index 000000000000..d0b1755d77d2
> > --- /dev/null
> > +++ b/drivers/gpu/drm/verisilicon/vs_simple_enc.c
> > @@ -0,0 +1,190 @@
> > +// SPDX-License-Identifier: GPL-2.0
> > +/*
> > + * Copyright (C) 2020 VeriSilicon Holdings Co., Ltd.
> 
> Now it is 2024, so the copyright should probably cover the range.
Ok ,will fix it
> 
> > + */
> > +#include <linux/component.h>
> > +#include <linux/of_device.h>
> > +#include <linux/module.h>
> > +#include <linux/regmap.h>
> > +#include <linux/media-bus-format.h>
> > +#include <linux/mfd/syscon.h>
> > +#include <linux/platform_device.h>
> > +#include <linux/of.h>
> > +
> > +#include <drm/drm_atomic_helper.h>
> > +#include <drm/drm_bridge.h>
> > +#include <drm/drm_crtc_helper.h>
> > +#include <drm/drm_of.h>
> > +
> > +#include "vs_crtc.h"
> > +#include "vs_simple_enc.h"
> > +
> > +static const struct simple_encoder_priv dsi_priv = {
> > +	.encoder_type = DRM_MODE_ENCODER_DSI
> 
> So, is it 'simple' aka something generic or DSI? In the latter case, please rename
> it accordingly.
Ok will done 
> 
> > +};
> > +
> > +static inline struct vs_simple_encoder *to_simple_encoder(struct
> > +drm_encoder *enc) {
> > +	return container_of(enc, struct vs_simple_encoder, encoder); }
> > +
> > +static int encoder_parse_dt(struct device *dev) {
> > +	struct vs_simple_encoder *simple = dev_get_drvdata(dev);
> > +	unsigned int args[2];
> > +
> > +	simple->dss_regmap =
> syscon_regmap_lookup_by_phandle_args(dev->of_node,
> > +								  "starfive,syscon",
> > +								  2, args);
> > +
> > +	if (IS_ERR(simple->dss_regmap)) {
> > +		return dev_err_probe(dev, PTR_ERR(simple->dss_regmap),
> > +				     "getting the regmap failed\n");
> > +	}
> > +
> > +	simple->offset = args[0];
> > +	simple->mask = args[1];
> 
> Is the value that you've read platform dependent or use case dependent?
> What is the actual value being written? Why are you using syscon for it?

The syscon is used to select crtcs binded with encoder,
If this encoder binds to crtc0 , set the syscon reg bit0 = 1
If this encoder binds to crtc1 , set the syscon reg bit1 = 1 (0x2)
Maybe I can do this by the possible_crtc instead of using args from dts


> 
> > +
> > +	return 0;
> > +}
> > +
> > +static void vs_encoder_atomic_enable(struct drm_encoder *encoder,
> > +struct drm_atomic_state *state) {
> > +	struct vs_simple_encoder *simple = to_simple_encoder(encoder);
> > +
> > +	regmap_update_bits(simple->dss_regmap, simple->offset, simple->mask,
> > +simple->mask);
> 
> 
> A purist in me would ask to have separate mask and value to write.
Understand , will avoid this action 
> 
> > +}
> 
> Is it necessary to clear those bits when stopping the stream?
No need to do this , if clear those bits , the encoder will point to a unknown crtc
> 
> 
> [skipped the rest]
> 
> > +
> > +
> > +struct platform_driver simple_encoder_driver = {
> > +	.probe = vs_encoder_probe,
> > +	.remove = vs_encoder_remove,
> > +	.driver = {
> > +		.name = "vs-simple-encoder",
> > +		.of_match_table = of_match_ptr(simple_encoder_dt_match),
> > +	},
> > +};
> > +
> > +MODULE_DESCRIPTION("Simple Encoder Driver");
> 
> VeriSilicon DSI Encoder
Ok  will done
> 
> > +MODULE_LICENSE("GPL");
> > diff --git a/drivers/gpu/drm/verisilicon/vs_simple_enc.h
> > b/drivers/gpu/drm/verisilicon/vs_simple_enc.h
> > new file mode 100644
> > index 000000000000..73e356bfeb2c
> > --- /dev/null
> > +++ b/drivers/gpu/drm/verisilicon/vs_simple_enc.h
> > @@ -0,0 +1,25 @@
> > +/* SPDX-License-Identifier: GPL-2.0 */
> > +/*
> > + * Copyright (C) 2022 VeriSilicon Holdings Co., Ltd.
> > + */
> > +
> > +#ifndef __VS_SIMPLE_ENC_H_
> > +#define __VS_SIMPLE_ENC_H_
> > +
> > +#include <drm/drm_encoder.h>
> > +
> > +struct simple_encoder_priv {
> > +	unsigned char encoder_type;
> > +};
> > +
> > +struct vs_simple_encoder {
> > +	struct drm_encoder encoder;
> > +	struct device *dev;
> > +	const struct simple_encoder_priv *priv;
> > +	struct regmap *dss_regmap;
> > +	unsigned int offset;
> > +	unsigned int mask;
> > +};
> 
> Is there a need for aheader for the encoder? Can you move the definitions to
> the source file?
Ok will done 
> 
> > +
> > +extern struct platform_driver simple_encoder_driver; #endif /*
> > +__VS_SIMPLE_ENC_H_ */
> > --
> > 2.27.0
> >
> 
> --
> With best wishes
> Dmitry

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ