[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <b5797453-3e19-469f-8a0b-71fe4c5add1a@intel.com>
Date: Mon, 24 Jun 2024 16:12:04 +0800
From: Yi Liu <yi.l.liu@...el.com>
To: Lu Baolu <baolu.lu@...ux.intel.com>, Joerg Roedel <joro@...tes.org>,
"Kevin Tian" <kevin.tian@...el.com>, Jacob Pan
<jacob.jun.pan@...ux.intel.com>
CC: Will Deacon <will@...nel.org>, Robin Murphy <robin.murphy@....com>,
<iommu@...ts.linux.dev>, <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH 1/2] iommu/vt-d: Convert dmar_ats_supported() to return
bool
On 2024/6/24 13:25, Lu Baolu wrote:
> dmar_ats_supported() returns an integer that is used as a boolean. Since
> it all it needs is to return true or false, change the return type from
nit: a redundant "it" is used here.
> int to bool to make it a bit more readable and obvious.
>
> Cleanup this helper accordingly with no functional change intended.
>
> Signed-off-by: Lu Baolu <baolu.lu@...ux.intel.com>
> ---
> drivers/iommu/intel/iommu.c | 33 ++++++++++++++++++---------------
> 1 file changed, 18 insertions(+), 15 deletions(-)
>
> diff --git a/drivers/iommu/intel/iommu.c b/drivers/iommu/intel/iommu.c
> index 38cda454fc64..07e394dfccc1 100644
> --- a/drivers/iommu/intel/iommu.c
> +++ b/drivers/iommu/intel/iommu.c
> @@ -3043,15 +3043,15 @@ static struct dmar_satc_unit *dmar_find_matched_satc_unit(struct pci_dev *dev)
> return satcu;
> }
>
> -static int dmar_ats_supported(struct pci_dev *dev, struct intel_iommu *iommu)
> +static bool dmar_ats_supported(struct pci_dev *dev, struct intel_iommu *iommu)
> {
> - int i, ret = 1;
> - struct pci_bus *bus;
> struct pci_dev *bridge = NULL;
> - struct device *tmp;
> - struct acpi_dmar_atsr *atsr;
> struct dmar_atsr_unit *atsru;
> struct dmar_satc_unit *satcu;
> + struct acpi_dmar_atsr *atsr;
> + struct pci_bus *bus;
> + struct device *tmp;
> + int i;
>
> dev = pci_physfn(dev);
> satcu = dmar_find_matched_satc_unit(dev);
> @@ -3069,11 +3069,11 @@ static int dmar_ats_supported(struct pci_dev *dev, struct intel_iommu *iommu)
> bridge = bus->self;
> /* If it's an integrated device, allow ATS */
> if (!bridge)
> - return 1;
> + return true;
> /* Connected via non-PCIe: no ATS */
> if (!pci_is_pcie(bridge) ||
> pci_pcie_type(bridge) == PCI_EXP_TYPE_PCI_BRIDGE)
> - return 0;
> + return false;
> /* If we found the root port, look it up in the ATSR */
> if (pci_pcie_type(bridge) == PCI_EXP_TYPE_ROOT_PORT)
> break;
> @@ -3085,18 +3085,21 @@ static int dmar_ats_supported(struct pci_dev *dev, struct intel_iommu *iommu)
> if (atsr->segment != pci_domain_nr(dev->bus))
> continue;
>
> - for_each_dev_scope(atsru->devices, atsru->devices_cnt, i, tmp)
> - if (tmp == &bridge->dev)
> - goto out;
> + for_each_dev_scope(atsru->devices, atsru->devices_cnt, i, tmp) {
> + if (tmp == &bridge->dev) {
> + rcu_read_unlock();
> + return true;
> + }
> + }
>
> - if (atsru->include_all)
> - goto out;
> + if (atsru->include_all) {
> + rcu_read_unlock();
> + return true;
It appears to me that two gotos is better than opening code. :) Anyhow.
Reviewed-by: Yi Liu <yi.l.liu@...el.com>
> + }
> }
> - ret = 0;
> -out:
> rcu_read_unlock();
>
> - return ret;
> + return false;
> }
>
> int dmar_iommu_notify_scope_dev(struct dmar_pci_notify_info *info)
--
Regards,
Yi Liu
Powered by blists - more mailing lists