lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Mon, 1 Jul 2024 07:44:00 -0700
From: Guenter Roeck <linux@...ck-us.net>
To: Quentin Schulz <quentin.schulz@...rry.de>, linux-hwmon@...r.kernel.org
Cc: linux-kernel@...r.kernel.org, Farouk Bouabid <farouk.bouabid@...rry.de>
Subject: Re: [PATCH 07/10] hwmon: (amc2821) Use BIT() and GENMASK()

On 7/1/24 04:31, Quentin Schulz wrote:
> Hi Guenter,
> 
> On 6/28/24 5:13 PM, Guenter Roeck wrote:
>> Use BIT() and GENMASK() for bit and mask definitions
>> to help distinguish bit and mask definitions from other
>> defines and to make the code easier to read.
>>
>> Signed-off-by: Guenter Roeck <linux@...ck-us.net>
>> ---
>>   drivers/hwmon/amc6821.c | 71 +++++++++++++++++++++--------------------
>>   1 file changed, 36 insertions(+), 35 deletions(-)
>>
>> diff --git a/drivers/hwmon/amc6821.c b/drivers/hwmon/amc6821.c
>> index 03ce2e3ffd86..042e2044de7b 100644
>> --- a/drivers/hwmon/amc6821.c
>> +++ b/drivers/hwmon/amc6821.c
>> @@ -8,6 +8,7 @@
>>    * Copyright (C) 2007 Hans J. Koch <hjk@...sjkoch.de>
>>    */
>> +#include <linux/bits.h>
>>   #include <linux/err.h>
>>   #include <linux/hwmon.h>
>>   #include <linux/hwmon-sysfs.h>
>> @@ -68,46 +69,46 @@ enum chips { amc6821 };
>>   #define AMC6821_REG_TACH_SETTINGL    0x1e
>>   #define AMC6821_REG_TACH_SETTINGH    0x1f
>> -#define AMC6821_CONF1_START        0x01
>> -#define AMC6821_CONF1_FAN_INT_EN    0x02
>> -#define AMC6821_CONF1_FANIE        0x04
>> -#define AMC6821_CONF1_PWMINV        0x08
>> -#define AMC6821_CONF1_FAN_FAULT_EN    0x10
>> -#define AMC6821_CONF1_FDRC0        0x20
>> -#define AMC6821_CONF1_FDRC1        0x40
>> -#define AMC6821_CONF1_THERMOVIE        0x80
>> +#define AMC6821_CONF1_START        BIT(0)
>> +#define AMC6821_CONF1_FAN_INT_EN    BIT(1)
>> +#define AMC6821_CONF1_FANIE        BIT(2)
>> +#define AMC6821_CONF1_PWMINV        BIT(3)
>> +#define AMC6821_CONF1_FAN_FAULT_EN    BIT(4)
>> +#define AMC6821_CONF1_FDRC0        BIT(5)
>> +#define AMC6821_CONF1_FDRC1        BIT(7)
> 
> Should be BIT(6) here if I'm not mistaken.
> 

Yes, I had fixed that later but accidentally applied the fix to later patch.

Guenter


Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ