[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20240702234930.flwbtga3iege66jr@master>
Date: Tue, 2 Jul 2024 23:49:30 +0000
From: Wei Yang <richard.weiyang@...il.com>
To: David Hildenbrand <david@...hat.com>
Cc: Andrew Morton <akpm@...ux-foundation.org>,
Wei Yang <richard.weiyang@...il.com>, brauner@...nel.org,
oleg@...hat.com, mjguzik@...il.com, tandersen@...flix.com,
linux-kernel@...r.kernel.org, Mike Rapoport <rppt@...nel.org>
Subject: Re: [PATCH v2 1/2] kernel/fork.c: get totalram_pages from memblock
to calculate max_threads
On Tue, Jul 02, 2024 at 09:02:31AM +0200, David Hildenbrand wrote:
>On 02.07.24 06:26, Andrew Morton wrote:
>> On Mon, 1 Jul 2024 01:34:09 +0000 Wei Yang <richard.weiyang@...il.com> wrote:
>>
>> > Since we plan to move the accounting into __free_pages_core(),
>> > totalram_pages may not represent the total usable pages on system
>> > at this point when defer_init is enabled.
>>
>> Yes, things like totalram_pages() are very old, and were a good idea at the
>> time, but things moved on.
>>
>> > Instead we can get the total usable pages from memblock directly.
>> >
>> > --- a/kernel/fork.c
>> > +++ b/kernel/fork.c
>> > @@ -44,6 +44,7 @@
>> > #include <linux/fs.h>
>> > #include <linux/mm.h>
>> > #include <linux/mm_inline.h>
>> > +#include <linux/memblock.h>
>> > #include <linux/nsproxy.h>
>> > #include <linux/capability.h>
>> > #include <linux/cpu.h>
>> > @@ -999,7 +1000,7 @@ void __init __weak arch_task_cache_init(void) { }
>> > static void set_max_threads(unsigned int max_threads_suggested)
>> > {
>> > u64 threads;
>> > - unsigned long nr_pages = totalram_pages();
>> > + unsigned long nr_pages = PHYS_PFN(memblock_phys_mem_size() - memblock_reserved_size());
>>
>> The result of this subtraction has meaning. Even if it is only used
>> once, I suspect it should be in a standalone function which has
>> documentation which describes that meaning. Having fork.c make an
>> open-coded poke into memblock internals seems wrong, no?
Agree, this is not a good practise.
>
>I was just about the comment the same thing:
>
>I'm starting to wonder if we should have a helper like
>
>memblock_estimated_nr_pages()
>
>or sth like that that abstracts this?
Hmm... not good at naming, I am ok with this.
I would prepare v2 with this. If someone have a better idea, I would change
it.
>
>--
>Cheers,
>
>David / dhildenb
--
Wei Yang
Help you, Help me
Powered by blists - more mailing lists