[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20240702074203.GA29410@lst.de>
Date: Tue, 2 Jul 2024 09:42:03 +0200
From: Christoph Hellwig <hch@....de>
To: "Pankaj Raghav (Samsung)" <kernel@...kajraghav.com>
Cc: david@...morbit.com, willy@...radead.org, chandan.babu@...cle.com,
djwong@...nel.org, brauner@...nel.org, akpm@...ux-foundation.org,
linux-kernel@...r.kernel.org, yang@...amperecomputing.com,
linux-mm@...ck.org, john.g.garry@...cle.com,
linux-fsdevel@...r.kernel.org, hare@...e.de, p.raghav@...sung.com,
mcgrof@...nel.org, gost.dev@...sung.com, cl@...amperecomputing.com,
linux-xfs@...r.kernel.org, hch@....de, Zi Yan <zi.yan@...t.com>
Subject: Re: [PATCH v8 06/10] iomap: fix iomap_dio_zero() for fs bs >
system page size
On Tue, Jun 25, 2024 at 11:44:16AM +0000, Pankaj Raghav (Samsung) wrote:
> -static int __init iomap_init(void)
> +static int __init iomap_pagecache_init(void)
> {
> return bioset_init(&iomap_ioend_bioset, 4 * (PAGE_SIZE / SECTOR_SIZE),
> offsetof(struct iomap_ioend, io_bio),
> BIOSET_NEED_BVECS);
> }
> -fs_initcall(iomap_init);
> +fs_initcall(iomap_pagecache_init);
s/iomap_pagecache_init/iomap_buffered_init/
We don't use pagecache naming anywhere else in the file.
> +/*
> + * Used for sub block zeroing in iomap_dio_zero()
> + */
> +#define ZERO_PAGE_64K_SIZE (65536)
just use SZ_64K
> +#define ZERO_PAGE_64K_ORDER (get_order(ZERO_PAGE_64K_SIZE))
No really point in having this.
> +static struct page *zero_page_64k;
This should be a folio. Encoding the size in the name is also really
weird and just creates churn when we have to increase it.
> + /*
> + * Max block size supported is 64k
> + */
> + WARN_ON_ONCE(len > ZERO_PAGE_64K_SIZE);
A WARN_ON without actually erroring out here is highly dangerous.
> +
> bio = iomap_dio_alloc_bio(iter, dio, 1, REQ_OP_WRITE | REQ_SYNC | REQ_IDLE);
Overly long line here.
> +
> +static int __init iomap_dio_init(void)
> +{
> + zero_page_64k = alloc_pages(GFP_KERNEL | __GFP_ZERO,
> + ZERO_PAGE_64K_ORDER);
> +
> + if (!zero_page_64k)
> + return -ENOMEM;
> +
> + set_memory_ro((unsigned long)page_address(zero_page_64k),
> + 1U << ZERO_PAGE_64K_ORDER);
What's the point of the set_memory_ro here? Yes, we won't write to
it, but it's hardly an attack vector and fragments the direct map.
Powered by blists - more mailing lists