[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <f90b597d-1e0f-497f-b092-3cb4d5f9602d@web.de>
Date: Wed, 3 Jul 2024 20:45:34 +0200
From: Markus Elfring <Markus.Elfring@....de>
To: Jim Quinlan <james.quinlan@...adcom.com>, linux-pci@...r.kernel.org,
bcm-kernel-feedback-list@...adcom.com, linux-arm-kernel@...ts.infradead.org,
linux-rpi-kernel@...ts.infradead.org, Bjorn Helgaas <bhelgaas@...gle.com>,
Cyril Brulebois <kibi@...ian.org>,
Lorenzo Pieralisi <lorenzo.pieralisi@....com>,
Nicolas Saenz Julienne <nsaenz@...nel.org>,
Stanimir Varbanov <svarbanov@...e.de>
Cc: LKML <linux-kernel@...r.kernel.org>,
Florian Fainelli <florian.fainelli@...adcom.com>,
Krzysztof Wilczyński <kw@...ux.com>,
Lorenzo Pieralisi <lpieralisi@...nel.org>, Rob Herring <robh@...nel.org>
Subject: Re: [PATCH 2/8] PCI: brcmstb: Use "clk_out" error path label
> [-- Attachment #1: Type: text/plain, Size: 1600 bytes --]
Can improved adjustments be provided as regular diff data (without an extra attachment)?
> Instead of invoking "clk_disable_unprepare(pcie->clk)" in
> a number of error paths.
* Can a wording approach (like the following) be a better change description?
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/Documentation/process/submitting-patches.rst?h=v6.10-rc6#n45
Add a jump target so that a bit of exception handling can be better reused
at the end of this function implementation.
* How do you think about to use a summary phrase like
“Use more common error handling code in brcm_pcie_probe()”?
…
> +++ b/drivers/pci/controller/pcie-brcmstb.c
…
> ret = reset_control_reset(pcie->rescal);
> - if (ret)
> + if (ret) {
> dev_err(&pdev->dev, "failed to deassert 'rescal'\n");
> + goto clk_out;
> + }
>
> ret = brcm_phy_start(pcie);
…
Does this software update complete the exception handling?
Would you like to add any tags (like “Fixes” and “Cc”) accordingly?
…
> @@ -1676,6 +1677,9 @@ static int brcm_pcie_probe(struct platform_device *pdev)
>
> return 0;
>
> +clk_out:
> + clk_disable_unprepare(pcie->clk);
> + return ret;
> fail:
…
I suggest to add a blank line before the second label.
Regards,
Markus
Powered by blists - more mailing lists