[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <55c508cf-9bc0-49a5-a286-8a9f3ff55220@redhat.com>
Date: Wed, 3 Jul 2024 21:14:43 -0400
From: Waiman Long <longman@...hat.com>
To: Chen Ridong <chenridong@...wei.com>, tj@...nel.org,
lizefan.x@...edance.com, hannes@...xchg.org
Cc: cgroups@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH v3 -next] cgroup/rstat: add force idle show helper
On 7/3/24 20:50, Chen Ridong wrote:
> In the function cgroup_base_stat_cputime_show, there are five
> instances of #ifdef, which makes the code not concise.
> To address this, add the function cgroup_force_idle_show
> to make the code more succinct.
>
> Signed-off-by: Chen Ridong <chenridong@...wei.com>
> ---
> kernel/cgroup/rstat.c | 36 ++++++++++++++++--------------------
> 1 file changed, 16 insertions(+), 20 deletions(-)
>
> diff --git a/kernel/cgroup/rstat.c b/kernel/cgroup/rstat.c
> index fb8b49437573..1568558e36e5 100644
> --- a/kernel/cgroup/rstat.c
> +++ b/kernel/cgroup/rstat.c
> @@ -594,49 +594,45 @@ static void root_cgroup_cputime(struct cgroup_base_stat *bstat)
> }
> }
>
> +
> +static void cgroup_force_idle_show(struct seq_file *seq, struct cgroup_base_stat *bstat)
> +{
> +#ifdef CONFIG_SCHED_CORE
> + u64 forceidle_time = bstat->forceidle_sum;
> +
> + do_div(forceidle_time, NSEC_PER_USEC);
> + seq_printf(seq, "core_sched.force_idle_usec %llu\n", forceidle_time);
> +#endif
> +}
> +
> void cgroup_base_stat_cputime_show(struct seq_file *seq)
> {
> struct cgroup *cgrp = seq_css(seq)->cgroup;
> u64 usage, utime, stime;
> - struct cgroup_base_stat bstat;
> -#ifdef CONFIG_SCHED_CORE
> - u64 forceidle_time;
> -#endif
>
> if (cgroup_parent(cgrp)) {
> cgroup_rstat_flush_hold(cgrp);
> usage = cgrp->bstat.cputime.sum_exec_runtime;
> cputime_adjust(&cgrp->bstat.cputime, &cgrp->prev_cputime,
> &utime, &stime);
> -#ifdef CONFIG_SCHED_CORE
> - forceidle_time = cgrp->bstat.forceidle_sum;
> -#endif
> cgroup_rstat_flush_release(cgrp);
> } else {
> - root_cgroup_cputime(&bstat);
> - usage = bstat.cputime.sum_exec_runtime;
> - utime = bstat.cputime.utime;
> - stime = bstat.cputime.stime;
> -#ifdef CONFIG_SCHED_CORE
> - forceidle_time = bstat.forceidle_sum;
> -#endif
> + root_cgroup_cputime(&cgrp->bstat);
> + usage = cgrp->bstat.cputime.sum_exec_runtime;
> + utime = cgrp->bstat.cputime.utime;
> + stime = cgrp->bstat.cputime.stime;
Just a simple comment saying that you are reusing the root cgroup bstat
which is otherwise not being used will help readability.
Other than that, the change LGTM.
Cheers,
Longman
> }
>
> do_div(usage, NSEC_PER_USEC);
> do_div(utime, NSEC_PER_USEC);
> do_div(stime, NSEC_PER_USEC);
> -#ifdef CONFIG_SCHED_CORE
> - do_div(forceidle_time, NSEC_PER_USEC);
> -#endif
>
> seq_printf(seq, "usage_usec %llu\n"
> "user_usec %llu\n"
> "system_usec %llu\n",
> usage, utime, stime);
>
> -#ifdef CONFIG_SCHED_CORE
> - seq_printf(seq, "core_sched.force_idle_usec %llu\n", forceidle_time);
> -#endif
> + cgroup_force_idle_show(seq, &cgrp->bstat);
> }
>
> /* Add bpf kfuncs for cgroup_rstat_updated() and cgroup_rstat_flush() */
Powered by blists - more mailing lists