[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <c8c88b6adaa5b5331bf336cfb2fe29f98f82c37e.camel@redhat.com>
Date: Thu, 04 Jul 2024 21:24:17 -0400
From: Maxim Levitsky <mlevitsk@...hat.com>
To: Sean Christopherson <seanjc@...gle.com>, Paolo Bonzini
<pbonzini@...hat.com>, Vitaly Kuznetsov <vkuznets@...hat.com>
Cc: kvm@...r.kernel.org, linux-kernel@...r.kernel.org, Hou Wenlong
<houwenlong.hwl@...group.com>, Kechen Lu <kechenl@...dia.com>, Oliver Upton
<oliver.upton@...ux.dev>, Binbin Wu <binbin.wu@...ux.intel.com>, Yang
Weijiang <weijiang.yang@...el.com>, Robert Hoo <robert.hoo.linux@...il.com>
Subject: Re: [PATCH v2 21/49] KVM: x86: Add a macro to init CPUID features
that are 64-bit only
On Fri, 2024-05-17 at 10:38 -0700, Sean Christopherson wrote:
> Add a macro to mask-in feature flags that are supported only on 64-bit
> kernels/KVM. In addition to reducing overall #ifdeffery, using a macro
> will allow hardening the kvm_cpu_cap initialization sequences to assert
> that the features being advertised are indeed included in the word being
> initialized. And arguably using *F() macros through is more readable.
>
> No functional change intended.
>
> Signed-off-by: Sean Christopherson <seanjc@...gle.com>
> ---
> arch/x86/kvm/cpuid.c | 22 ++++++++++------------
> 1 file changed, 10 insertions(+), 12 deletions(-)
>
> diff --git a/arch/x86/kvm/cpuid.c b/arch/x86/kvm/cpuid.c
> index 5a4d6138c4f1..5e3b97d06374 100644
> --- a/arch/x86/kvm/cpuid.c
> +++ b/arch/x86/kvm/cpuid.c
> @@ -70,6 +70,12 @@ u32 xstate_required_size(u64 xstate_bv, bool compacted)
> (boot_cpu_has(X86_FEATURE_##name) ? F(name) : 0); \
> })
>
> +/* Features that KVM supports only on 64-bit kernels. */
> +#define X86_64_F(name) \
> +({ \
> + (IS_ENABLED(CONFIG_X86_64) ? F(name) : 0); \
> +})
> +
> /*
> * Raw Feature - For features that KVM supports based purely on raw host CPUID,
> * i.e. that KVM virtualizes even if the host kernel doesn't use the feature.
> @@ -639,15 +645,6 @@ static __always_inline void kvm_cpu_cap_init(enum cpuid_leafs leaf, u32 mask)
>
> void kvm_set_cpu_caps(void)
> {
> -#ifdef CONFIG_X86_64
> - unsigned int f_gbpages = F(GBPAGES);
> - unsigned int f_lm = F(LM);
> - unsigned int f_xfd = F(XFD);
> -#else
> - unsigned int f_gbpages = 0;
> - unsigned int f_lm = 0;
> - unsigned int f_xfd = 0;
> -#endif
> memset(kvm_cpu_caps, 0, sizeof(kvm_cpu_caps));
>
> BUILD_BUG_ON(sizeof(kvm_cpu_caps) - (NKVMCAPINTS * sizeof(*kvm_cpu_caps)) >
> @@ -744,7 +741,8 @@ void kvm_set_cpu_caps(void)
> );
>
> kvm_cpu_cap_init(CPUID_D_1_EAX,
> - F(XSAVEOPT) | F(XSAVEC) | F(XGETBV1) | F(XSAVES) | f_xfd
> + F(XSAVEOPT) | F(XSAVEC) | F(XGETBV1) | F(XSAVES) |
> + X86_64_F(XFD)
> );
>
> kvm_cpu_cap_init_kvm_defined(CPUID_12_EAX,
> @@ -766,8 +764,8 @@ void kvm_set_cpu_caps(void)
> F(MTRR) | F(PGE) | F(MCA) | F(CMOV) |
> F(PAT) | F(PSE36) | 0 /* Reserved */ |
> F(NX) | 0 /* Reserved */ | F(MMXEXT) | F(MMX) |
> - F(FXSR) | F(FXSR_OPT) | f_gbpages | F(RDTSCP) |
> - 0 /* Reserved */ | f_lm | F(3DNOWEXT) | F(3DNOW)
> + F(FXSR) | F(FXSR_OPT) | X86_64_F(GBPAGES) | F(RDTSCP) |
> + 0 /* Reserved */ | X86_64_F(LM) | F(3DNOWEXT) | F(3DNOW)
> );
>
> if (!tdp_enabled && IS_ENABLED(CONFIG_X86_64))
This is a good cleanup.
Reviewed-by: Maxim Levitsky <mlevitsk@...hat.com>
Best regards,
Maxim Levitsky
Powered by blists - more mailing lists