[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20240712-iio-regulator-refactor-round-3-v1-0-835017bae43d@baylibre.com>
Date: Fri, 12 Jul 2024 11:03:51 -0500
From: David Lechner <dlechner@...libre.com>
To: Jonathan Cameron <jic23@...nel.org>,
Marius Cristea <marius.cristea@...rochip.com>,
Marcus Folkesson <marcus.folkesson@...il.com>,
Kent Gustavsson <kent@...oris.se>
Cc: David Lechner <dlechner@...libre.com>,
Liam Girdwood <lgirdwood@...il.com>,
Mark Brown <broonie@...nel.org>,
linux-iio@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: [PATCH 0/6] iio: use devm_regulator_get_enable_read_voltage round 3
This is the third round of patches to convert IIO drivers to use the
new devm_regulator_get_enable_read_voltage() helper function.
This time, we are converting some Microchip drivers. These weren't as
trivial as some other drivers because of nested functions that need
to know info about the reference voltage, but for the most part, should
be fairly straightforward. And there is a bonus to remove a remove()
callback in one of the drivers.
---
David Lechner (6):
iio: dac: mcp4728: rename err to ret in probe function
iio: dac: mcp4728: use devm_regulator_get_enable_read_voltage()
iio: dac: mcp4922: use devm_regulator_get_enable_read_voltage()
iio: dac: mcp4922: drop remove() callback
iio: adc: mcp3564: use devm_regulator_get_enable_read_voltage()
iio: adc: mcp3911: use devm_regulator_get_enable_read_voltage()
drivers/iio/adc/mcp3564.c | 54 +++++++++++++------------------------------
drivers/iio/adc/mcp3911.c | 59 +++++++++++++----------------------------------
drivers/iio/dac/mcp4728.c | 45 +++++++++++-------------------------
drivers/iio/dac/mcp4922.c | 47 ++++++-------------------------------
4 files changed, 52 insertions(+), 153 deletions(-)
---
base-commit: 986da024b99a72e64f6bdb3f3f0e52af024b1f50
change-id: 20240712-iio-regulator-refactor-round-3-17f2a82d2181
Powered by blists - more mailing lists