[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <c105871a-6462-4678-9f0c-b2ed5a254bb1@heusel.eu>
Date: Fri, 19 Jul 2024 17:41:04 +0200
From: Christian Heusel <christian@...sel.eu>
To: Markus Elfring <Markus.Elfring@....de>
Cc: linux-perf-users@...r.kernel.org, kernel-janitors@...r.kernel.org,
Adrian Hunter <adrian.hunter@...el.com>, Alexander Shishkin <alexander.shishkin@...ux.intel.com>,
Arnaldo Carvalho de Melo <acme@...nel.org>, Ian Rogers <irogers@...gle.com>, Ingo Molnar <mingo@...hat.com>,
Jiri Olsa <jolsa@...nel.org>, Kan Liang <kan.liang@...ux.intel.com>,
Mark Rutland <mark.rutland@....com>, Namhyung Kim <namhyung@...nel.org>,
Peter Zijlstra <peterz@...radead.org>, LKML <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH] perf trace: Avoid duplicate code in fprintf_duration()
On 24/07/19 04:17PM, Markus Elfring wrote:
> From: Markus Elfring <elfring@...rs.sourceforge.net>
> Date: Fri, 19 Jul 2024 16:12:51 +0200
>
> Adjust the colour selection so that a bit of duplicate code can be avoided
> in this function implementation.
>
> Signed-off-by: Markus Elfring <elfring@...rs.sourceforge.net>
> ---
> tools/perf/builtin-trace.c | 14 +++++++++-----
> 1 file changed, 9 insertions(+), 5 deletions(-)
>
> diff --git a/tools/perf/builtin-trace.c b/tools/perf/builtin-trace.c
> index 8449f2beb54d..e29ae5cb95b0 100644
> --- a/tools/perf/builtin-trace.c
> +++ b/tools/perf/builtin-trace.c
> @@ -1258,12 +1258,16 @@ static size_t fprintf_duration(unsigned long t, bool calculated, FILE *fp)
>
> if (!calculated)
> printed += fprintf(fp, " ");
> - else if (duration >= 1.0)
> - printed += color_fprintf(fp, PERF_COLOR_RED, "%6.3f ms", duration);
> - else if (duration >= 0.01)
> - printed += color_fprintf(fp, PERF_COLOR_YELLOW, "%6.3f ms", duration);
> else
> - printed += color_fprintf(fp, PERF_COLOR_NORMAL, "%6.3f ms", duration);
> + printed += color_fprintf(fp,
> + (duration >= 1.0
> + ? PERF_COLOR_RED
> + : (duration >= 0.01
> + ? PERF_COLOR_YELLOW
> + : PERF_COLOR_NORMAL)),
> + "%6.3f ms",
> + duration);
Why is this a desirable change? Folding the if-statements into the
ternary operator makes the code quite unreadable compared to what it was
like before and doesn't give any obvious improvement.
Download attachment "signature.asc" of type "application/pgp-signature" (834 bytes)
Powered by blists - more mailing lists