[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <01e36e70-4e3e-464f-a14b-57a892b07f61@redhat.com>
Date: Thu, 1 Aug 2024 11:33:18 +0200
From: David Hildenbrand <david@...hat.com>
To: Thorsten Blum <thorsten.blum@...lux.com>, jglisse@...hat.com,
akpm@...ux-foundation.org
Cc: linux-mm@...ck.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] lib: test_hmm: Use min() to improve dmirror_exclusive()
On 26.07.24 15:12, Thorsten Blum wrote:
> Use min() to simplify the dmirror_exclusive() function and improve its
> readability.
>
> Signed-off-by: Thorsten Blum <thorsten.blum@...lux.com>
> ---
> lib/test_hmm.c | 5 +----
> 1 file changed, 1 insertion(+), 4 deletions(-)
>
> diff --git a/lib/test_hmm.c b/lib/test_hmm.c
> index ee20e1f9bae9..056f2e411d7b 100644
> --- a/lib/test_hmm.c
> +++ b/lib/test_hmm.c
> @@ -799,10 +799,7 @@ static int dmirror_exclusive(struct dmirror *dmirror,
> unsigned long mapped = 0;
> int i;
>
> - if (end < addr + (ARRAY_SIZE(pages) << PAGE_SHIFT))
> - next = end;
> - else
> - next = addr + (ARRAY_SIZE(pages) << PAGE_SHIFT);
> + next = min(end, addr + (ARRAY_SIZE(pages) << PAGE_SHIFT));
Reviewed-by: David Hildenbrand <david@...hat.com>
--
Cheers,
David / dhildenb
Powered by blists - more mailing lists