lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <fc8a6e83-98fa-4809-8b05-ea9f94dd2c71@linuxfoundation.org>
Date: Fri, 2 Aug 2024 15:20:51 -0600
From: Shuah Khan <skhan@...uxfoundation.org>
To: Thomas Weißschuh <linux@...ssschuh.net>
Cc: Willy Tarreau <w@....eu>, Shuah Khan <shuah@...nel.org>,
 linux-kernel@...r.kernel.org, linux-kselftest@...r.kernel.org,
 Shuah Khan <skhan@...uxfoundation.org>
Subject: Re: [PATCH 1/2] tools/nolibc: add support for [v]sscanf()

On 8/2/24 09:48, Thomas Weißschuh wrote:
> On 2024-07-31 17:01:09+0000, Shuah Khan wrote:
>> On 7/31/24 12:32, Thomas Weißschuh wrote:
>>> The implementation is limited and only supports numeric arguments.
>>
>> I would like to see more information in here. Why is this needed
>> etc. etc.
> 
> Ack.
> 
>>>
>>> Signed-off-by: Thomas Weißschuh <linux@...ssschuh.net>
>>> ---
>>>    tools/include/nolibc/stdio.h                 | 93 ++++++++++++++++++++++++++++
>>>    tools/testing/selftests/nolibc/nolibc-test.c | 59 ++++++++++++++++++
>>>    2 files changed, 152 insertions(+)
>>>
>>> diff --git a/tools/include/nolibc/stdio.h b/tools/include/nolibc/stdio.h
>>> index c968dbbc4ef8..d63c45c06d8e 100644
>>> --- a/tools/include/nolibc/stdio.h
>>> +++ b/tools/include/nolibc/stdio.h
>>> @@ -348,6 +348,99 @@ int printf(const char *fmt, ...)
>>>    	return ret;
>>>    }
>>> +static __attribute__((unused))
>>> +int vsscanf(const char *str, const char *format, va_list args)
>>
>> Is there a reason why you didn't use the same code in lib/vsprintf.c?
>> You could simply duplicate the code here?
> 
> lib/vsprintf.c is GPL-2.0-only while nolibc is LGPL-2.1 OR MIT,
> so code reuse isn't really possible.
> Furthermore I think the vsprintf.c implements the custom kernel formats,
> while nolibc should use posix ones.

Ack.

> 
>> With all these libc functionality added, it isn't nolibc looks like :)
> 
> Well :-)
> 
> The main motivation is to provide kselftests compatibility.
> Maybe Willy disagrees.
> 
>>> +{

>>> +done:
>>> +	return matches;
>>> +}
>>> +
>>> +static __attribute__((unused, format(scanf, 2, 3)))
>>> +int sscanf(const char *str, const char *format, ...)
>>> +{
>>> +	va_list args;
>>> +	int ret;
>>> +
>>> +	va_start(args, format);
>>> +	ret = vsscanf(str, format, args);
>>> +	va_end(args);
>>> +	return ret;
>>> +}
>>> +
>>>    static __attribute__((unused))
>>>    void perror(const char *msg)
>>>    {
>>> diff --git a/tools/testing/selftests/nolibc/nolibc-test.c b/tools/testing/selftests/nolibc/nolibc-test.c
>>> index 093d0512f4c5..addbceb0b276 100644
>>> --- a/tools/testing/selftests/nolibc/nolibc-test.c
>>> +++ b/tools/testing/selftests/nolibc/nolibc-test.c
>>> @@ -1277,6 +1277,64 @@ static int expect_vfprintf(int llen, int c, const char *expected, const char *fm
>>>    	return ret;
>>>    }
>>> +static int test_scanf(void)

Is there a rationale for the return values 1 - 14. It will be
easier to understand if there are comments in the code.

>>> +{
>>> +	unsigned long long ull;
>>> +	unsigned long ul;
>>> +	unsigned int u;
>>> +	long long ll;
>>> +	long l;
>>> +	void *p;
>>> +	int i;
>>> +
>>> +	if (sscanf("", "foo") != EOF)
>>> +		return 1;
>>> +
>>> +	if (sscanf("foo", "foo") != 0)
>>> +		return 2;
>>> +
>>> +	if (sscanf("123", "%d", &i) != 1)
>>> +		return 3;>>> +
>>> +	if (i != 123)
>>> +		return 4;
>>> +
>>> +	if (sscanf("a123b456c0x90", "a%db%uc%p", &i, &u, &p) != 3)
>>> +		return 5;
>>> +
>>> +	if (i != 123)
>>> +		return 6;
>>> +
>>> +	if (u != 456)
>>> +		return 7;
>>> +
>>> +	if (p != (void *)0x90)
>>> +		return 8;
>>> +
>>> +	if (sscanf("a    b1", "a b%d", &i) != 1)
>>> +		return 9;
>>> +
>>> +	if (i != 1)
>>> +		return 10;
>>> +
>>> +	if (sscanf("a%1", "a%%%d", &i) != 1)
>>> +		return 11;
>>> +
>>> +	if (i != 1)
>>> +		return 12;
>>> +
>>> +	if (sscanf("1|2|3|4|5|6",
>>> +		   "%d|%ld|%lld|%u|%lu|%llu",
>>> +		   &i, &l, &ll, &u, &ul, &ull) != 6)
>>> +		return 13;
>>> +
>>> +	if (i != 1 || l != 2 || ll != 3 ||
>>> +	    u != 4 || ul != 5 || ull != 6)
>>> +		return 14;
>>> +
>>> +	return 0;
>>
>> Can we simplify this code? It is hard to read code with too
>> many conditions. Maybe defining an array test conditions
>> instead of a series ifs.
> 
> I tried that and didn't find a way.
> Any pointers are welcome.

I played with this some and couldn't think of way to simplify
this without making it hard to read. It would help adding
comments though.

thanks,
-- Shuah

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ