[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <96843dc5-6c7a-4b93-84a2-1cdc4da9ce85@wanadoo.fr>
Date: Fri, 2 Aug 2024 15:23:35 +0200
From: Christophe JAILLET <christophe.jaillet@...adoo.fr>
To: Qiang Ma <maqianga@...ontech.com>, dmitry.torokhov@...il.com,
hdegoede@...hat.com
Cc: linux-input@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH V2] Input: atkbd - fix LED state at suspend/resume
Le 02/08/2024 à 11:36, Qiang Ma a écrit :
> After we turn on the keyboard CAPSL LED and let the system suspend,
> the keyboard LED is not off, and the kernel log is as follows:
>
> [ 185.987574] i8042: [44060] ed -> i8042 (kbd-data)
> [ 185.988057] i8042: [44061] ** <- i8042 (interrupt, 0, 1)
> [ 185.988067] i8042: [44061] 04 -> i8042 (kbd-data)
> [ 185.988248] i8042: [44061] ** <- i8042 (interrupt, 0, 1)
>
> The log shows that after the command 0xed is sent, the data
> sent is 0x04 instead of 0x00.
>
> Solution:
> Add a bitmap variable ledon in the atkbd structure, and then set ledon
> according to code-value in the event, in the atkbd_set_leds() function,
> first look at the value of ledon, if it is 0, there is no need to
> look at the value of dev->led, otherwise, need to look at dev->led
> to determine the keyboard LED on/off.
>
> Signed-off-by: Qiang Ma <maqianga@...ontech.com>
> Signed-off-by: Christophe JAILLET <christophe.jaillet@...adoo.fr>
Hmmm, no.
I just made a few comments on v1.
That does not mean a Signed-off-by at all.
> ---
> V2:
> - Fixed formatting and spelling errors
> - Optimized some code
A good practice is also to give the link to previous versions. It can
help reviewers who maybe missed part of the story.
v1:
https://lore.kernel.org/all/20240726102730.24836-1-maqianga@uniontech.com/
>
> drivers/input/keyboard/atkbd.c | 31 +++++++++++++++++++++++--------
> 1 file changed, 23 insertions(+), 8 deletions(-)
>
> diff --git a/drivers/input/keyboard/atkbd.c b/drivers/input/keyboard/atkbd.c
> index 7f67f9f2946b..fb479bc78134 100644
> --- a/drivers/input/keyboard/atkbd.c
> +++ b/drivers/input/keyboard/atkbd.c
> @@ -237,6 +237,8 @@ struct atkbd {
> struct mutex mutex;
>
> struct vivaldi_data vdata;
> +
> + DECLARE_BITMAP(ledon, LED_CNT);
> };
>
> /*
> @@ -604,24 +606,32 @@ static int atkbd_set_repeat_rate(struct atkbd *atkbd)
> return ps2_command(&atkbd->ps2dev, ¶m, ATKBD_CMD_SETREP);
> }
>
> +#define ATKBD_DO_LED_TOGGLE(dev, atkbd, type, v, bits, on) \
Is there a real advantage for 'bits' and 'on'?
They always match with 'led' and 'ledon' below.
And 'atkbd' and 'dev' are already hard coded below anyway.
I just find it confusing and harder to read.
Also, in order to be less verbose, maybe ATKBD_LED_TOGGLE or
ATKBD_TOGGLE_LED would just be as clear with fewer char?
CJ
> +({ \
> + unsigned char __tmp = 0; \
> + if (test_bit(LED_##type, atkbd->on)) \
> + __tmp = test_bit(LED_##type, dev->bits) ? v : 0; \
> + __tmp; \
> +})
> +
> static int atkbd_set_leds(struct atkbd *atkbd)
> {
> struct input_dev *dev = atkbd->dev;
> unsigned char param[2];
>
> - param[0] = (test_bit(LED_SCROLLL, dev->led) ? 1 : 0)
> - | (test_bit(LED_NUML, dev->led) ? 2 : 0)
> - | (test_bit(LED_CAPSL, dev->led) ? 4 : 0);
> + param[0] = ATKBD_DO_LED_TOGGLE(dev, atkbd, SCROLLL, 1, led, ledon)
> + | ATKBD_DO_LED_TOGGLE(dev, atkbd, NUML, 2, led, ledon)
> + | ATKBD_DO_LED_TOGGLE(dev, atkbd, CAPSL, 4, led, ledon);
> if (ps2_command(&atkbd->ps2dev, param, ATKBD_CMD_SETLEDS))
> return -1;
>
> if (atkbd->extra) {
> param[0] = 0;
> - param[1] = (test_bit(LED_COMPOSE, dev->led) ? 0x01 : 0)
> - | (test_bit(LED_SLEEP, dev->led) ? 0x02 : 0)
> - | (test_bit(LED_SUSPEND, dev->led) ? 0x04 : 0)
> - | (test_bit(LED_MISC, dev->led) ? 0x10 : 0)
> - | (test_bit(LED_MUTE, dev->led) ? 0x20 : 0);
> + param[1] = ATKBD_DO_LED_TOGGLE(dev, atkbd, COMPOSE, 0x01, led, ledon)
> + | ATKBD_DO_LED_TOGGLE(dev, atkbd, SLEEP, 0x02, led, ledon)
> + | ATKBD_DO_LED_TOGGLE(dev, atkbd, SUSPEND, 0x04, led, ledon)
> + | ATKBD_DO_LED_TOGGLE(dev, atkbd, MISC, 0x10, led, ledon)
> + | ATKBD_DO_LED_TOGGLE(dev, atkbd, MUTE, 0x20, led, ledon);
> if (ps2_command(&atkbd->ps2dev, param, ATKBD_CMD_EX_SETLEDS))
> return -1;
> }
> @@ -695,6 +705,11 @@ static int atkbd_event(struct input_dev *dev,
> switch (type) {
>
> case EV_LED:
> + if (value)
> + __set_bit(code, atkbd->ledon);
> + else
> + __clear_bit(code, atkbd->ledon);
> +
> atkbd_schedule_event_work(atkbd, ATKBD_LED_EVENT_BIT);
> return 0;
>
Powered by blists - more mailing lists