lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20240805132159.gumu57vmj7hrru6o@quack3>
Date: Mon, 5 Aug 2024 15:21:59 +0200
From: Jan Kara <jack@...e.cz>
To: Joel Savitz <jsavitz@...hat.com>
Cc: linux-kernel@...r.kernel.org, Alexander Viro <viro@...iv.linux.org.uk>,
	Christian Brauner <brauner@...nel.org>, Jan Kara <jack@...e.cz>,
	linux-fsdevel@...r.kernel.org
Subject: Re: [PATCH] file: remove outdated comment after close_fd()

On Fri 02-08-24 22:54:55, Joel Savitz wrote:
> Cc: Alexander Viro <viro@...iv.linux.org.uk>
> Cc: Christian Brauner <brauner@...nel.org>
> Cc: Jan Kara <jack@...e.cz>
> Cc: linux-fsdevel@...r.kernel.org
> 
> The comment on EXPORT_SYMBOL(close_fd) was added in commit 2ca2a09d6215
> ("fs: add ksys_close() wrapper; remove in-kernel calls to sys_close()"),
> before commit 8760c909f54a ("file: Rename __close_fd to close_fd and remove
> the files parameter") gave the function its current name, however commit
> 1572bfdf21d4 ("file: Replace ksys_close with close_fd") removes the
> referenced caller entirely, obsoleting this comment.
> 
> Signed-off-by: Joel Savitz <jsavitz@...hat.com>

Looks good. Feel free to add:

Reviewed-by: Jan Kara <jack@...e.cz>

								Honza

> ---
>  fs/file.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/fs/file.c b/fs/file.c
> index a3b72aa64f11..cfc58b782bc4 100644
> --- a/fs/file.c
> +++ b/fs/file.c
> @@ -676,7 +676,7 @@ int close_fd(unsigned fd)
>  
>  	return filp_close(file, files);
>  }
> -EXPORT_SYMBOL(close_fd); /* for ksys_close() */
> +EXPORT_SYMBOL(close_fd);
>  
>  /**
>   * last_fd - return last valid index into fd table
> -- 
> 2.45.2
> 
-- 
Jan Kara <jack@...e.com>
SUSE Labs, CR

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ