lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20240809012410.marjxrio3sjequnn@airbuntu>
Date: Fri, 9 Aug 2024 02:24:10 +0100
From: Qais Yousef <qyousef@...alina.io>
To: Christian Loehle <christian.loehle@....com>
Cc: "Rafael J. Wysocki" <rafael@...nel.org>,
	Vincent Guittot <vincent.guittot@...aro.org>,
	"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
	linux-pm@...r.kernel.org, Ingo Molnar <mingo@...nel.org>,
	Peter Zijlstra <peterz@...radead.org>,
	Juri Lelli <juri.lelli@...hat.com>,
	Steven Rostedt <rostedt@...dmis.org>
Subject: Re: [PATCH] sched/cpufreq: Use USEC_PER_SEC for deadline task

Adding more sched folks to CC

On 08/06/24 14:41, Christian Loehle wrote:
> Convert the sugov deadline task attributes to use the available
> definitions to make them more readable.
> No functional change.
> 
> Signed-off-by: Christian Loehle <christian.loehle@....com>
> ---
>  kernel/sched/cpufreq_schedutil.c | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/kernel/sched/cpufreq_schedutil.c b/kernel/sched/cpufreq_schedutil.c
> index eece6244f9d2..012b38a04894 100644
> --- a/kernel/sched/cpufreq_schedutil.c
> +++ b/kernel/sched/cpufreq_schedutil.c
> @@ -654,9 +654,9 @@ static int sugov_kthread_create(struct sugov_policy *sg_policy)
>  		 * Fake (unused) bandwidth; workaround to "fix"
>  		 * priority inheritance.
>  		 */
> -		.sched_runtime	=  1000000,
> -		.sched_deadline = 10000000,
> -		.sched_period	= 10000000,
> +		.sched_runtime	= USEC_PER_SEC,
> +		.sched_deadline = 10 * USEC_PER_SEC,
> +		.sched_period	= 10 * USEC_PER_SEC,

I think NSEC_PER_MSEC is the correct one. The units in
include/uapi/linux/sched/types.h is not specified. Had to look at
sched-deadline.rst to figure it out.

Assuming I didn't get it wrong, mind adding the unit to types.h too?


Thanks!

--
Qais Yousef

>  	};
>  	struct cpufreq_policy *policy = sg_policy->policy;
>  	int ret;
> -- 
> 2.34.1

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ