[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <ef4053c9-6bc8-4b08-af8b-6a4a51100283@redhat.com>
Date: Wed, 14 Aug 2024 20:15:33 +0200
From: Paolo Bonzini <pbonzini@...hat.com>
To: Sean Christopherson <seanjc@...gle.com>
Cc: kvm@...r.kernel.org, linux-kernel@...r.kernel.org,
Chao Gao <chao.gao@...el.com>, Kai Huang <kai.huang@...el.com>
Subject: Re: [PATCH v3 5/8] KVM: Add arch hooks for enabling/disabling
virtualization
On 6/8/24 02:06, Sean Christopherson wrote:
> Add arch hooks that are invoked when KVM enables/disable virtualization.
> x86 will use the hooks to register an "emergency disable" callback, which
> is essentially an x86-specific shutdown notifier that is used when the
> kernel is doing an emergency reboot/shutdown/kexec.
>
> Add comments for the declarations to help arch code understand exactly
> when the callbacks are invoked. Alternatively, the APIs themselves could
> communicate most of the same info, but kvm_arch_pre_enable_virtualization()
> and kvm_arch_post_disable_virtualization() are a bit cumbersome, and make
> it a bit less obvious that they are intended to be implemented as a pair.
>
> Reviewed-by: Chao Gao <chao.gao@...el.com>
> Reviewed-by: Kai Huang <kai.huang@...el.com>
> Signed-off-by: Sean Christopherson <seanjc@...gle.com>
> ---
> include/linux/kvm_host.h | 14 ++++++++++++++
> virt/kvm/kvm_main.c | 14 ++++++++++++++
> 2 files changed, 28 insertions(+)
>
> diff --git a/include/linux/kvm_host.h b/include/linux/kvm_host.h
> index 96ad3e8b9ddb..12ef3beb4e47 100644
> --- a/include/linux/kvm_host.h
> +++ b/include/linux/kvm_host.h
> @@ -1514,6 +1514,20 @@ static inline void kvm_create_vcpu_debugfs(struct kvm_vcpu *vcpu) {}
> #endif
>
> #ifdef CONFIG_KVM_GENERIC_HARDWARE_ENABLING
> +/*
> + * kvm_arch_{enable,disable}_virtualization() are called on one CPU, under
> + * kvm_usage_lock, immediately after/before 0=>1 and 1=>0 transitions of
> + * kvm_usage_count, i.e. at the beginning of the generic hardware enabling
> + * sequence, and at the end of the generic hardware disabling sequence.
> + */
> +void kvm_arch_enable_virtualization(void);
> +void kvm_arch_disable_virtualization(void);
> +/*
> + * kvm_arch_hardware_{enable,disable}() are called on "every" CPU to do the
> + * actual twiddling of hardware bits. The hooks are called all online CPUs
> + * when KVM enables/disabled virtualization. Enabling/disabling is also done
> + * when a CPU is onlined/offlined (or Resumed/Suspended).
> + */
> int kvm_arch_hardware_enable(void);
> void kvm_arch_hardware_disable(void);
Since you are at it, rename these to
kvm_arch_{enable,disable}_virtualization_cpu()?
Paolo
> #endif
> diff --git a/virt/kvm/kvm_main.c b/virt/kvm/kvm_main.c
> index 7bdd744e4821..e20189a89a64 100644
> --- a/virt/kvm/kvm_main.c
> +++ b/virt/kvm/kvm_main.c
> @@ -5505,6 +5505,16 @@ static DEFINE_PER_CPU(bool, hardware_enabled);
> static DEFINE_MUTEX(kvm_usage_lock);
> static int kvm_usage_count;
>
> +__weak void kvm_arch_enable_virtualization(void)
> +{
> +
> +}
> +
> +__weak void kvm_arch_disable_virtualization(void)
> +{
> +
> +}
> +
> static int __kvm_enable_virtualization(void)
> {
> if (__this_cpu_read(hardware_enabled))
> @@ -5604,6 +5614,8 @@ static int kvm_enable_virtualization(void)
> if (kvm_usage_count++)
> return 0;
>
> + kvm_arch_enable_virtualization();
> +
> r = cpuhp_setup_state(CPUHP_AP_KVM_ONLINE, "kvm/cpu:online",
> kvm_online_cpu, kvm_offline_cpu);
> if (r)
> @@ -5634,6 +5646,7 @@ static int kvm_enable_virtualization(void)
> unregister_syscore_ops(&kvm_syscore_ops);
> cpuhp_remove_state(CPUHP_AP_KVM_ONLINE);
> err_cpuhp:
> + kvm_arch_disable_virtualization();
> --kvm_usage_count;
> return r;
> }
> @@ -5647,6 +5660,7 @@ static void kvm_disable_virtualization(void)
>
> unregister_syscore_ops(&kvm_syscore_ops);
> cpuhp_remove_state(CPUHP_AP_KVM_ONLINE);
> + kvm_arch_disable_virtualization();
> }
>
> static int kvm_init_virtualization(void)
Powered by blists - more mailing lists