[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID:
<OSZPR01MB8798549BD48777C0CB9A7B398B802@OSZPR01MB8798.jpnprd01.prod.outlook.com>
Date: Thu, 15 Aug 2024 06:43:01 +0000
From: "Shaopeng Tan (Fujitsu)" <tan.shaopeng@...itsu.com>
To: 'James Morse' <james.morse@....com>, "x86@...nel.org" <x86@...nel.org>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>
CC: Fenghua Yu <fenghua.yu@...el.com>, Reinette Chatre
<reinette.chatre@...el.com>, Thomas Gleixner <tglx@...utronix.de>, Ingo
Molnar <mingo@...hat.com>, Borislav Petkov <bp@...en8.de>, H Peter Anvin
<hpa@...or.com>, Babu Moger <Babu.Moger@....com>,
"shameerali.kolothum.thodi@...wei.com"
<shameerali.kolothum.thodi@...wei.com>, D Scott Phillips OS
<scott@...amperecomputing.com>, "carl@...amperecomputing.com"
<carl@...amperecomputing.com>, "lcherian@...vell.com" <lcherian@...vell.com>,
"bobo.shaobowang@...wei.com" <bobo.shaobowang@...wei.com>,
"baolin.wang@...ux.alibaba.com" <baolin.wang@...ux.alibaba.com>, Jamie Iles
<quic_jiles@...cinc.com>, Xin Hao <xhao@...ux.alibaba.com>,
"peternewman@...gle.com" <peternewman@...gle.com>, "dfustini@...libre.com"
<dfustini@...libre.com>, "amitsinght@...vell.com" <amitsinght@...vell.com>,
David Hildenbrand <david@...hat.com>, Rex Nie <rex.nie@...uarmicro.com>, Dave
Martin <dave.martin@....com>
Subject: RE: [PATCH v4 17/39] x86/resctrl: Rewrite and move the
for_each_*_rdt_resource() walkers
Hello James,
> Subject: [PATCH v4 17/39] x86/resctrl: Rewrite and move the
> for_each_*_rdt_resource() walkers
>
> The for_each_*_rdt_resource() helpers walk the architecture's array of
> structures, using the resctrl visible part as an iterator. These became
> over-complex when the structures were split into a filesystem and
> architecture-specific struct. This approach avoided the need to touch every call
> site, and was done before there was a helper to retrieve a resource by rid.
>
> Once the filesystem parts of resctrl are moved to /fs/, both the architecture's
> resource array, and the definition of those structures is no longer accessible. To
> support resctrl, each architecture would have to provide equally complex
> macros.
>
> Rewrite the macro to make use of resctrl_arch_get_resource(), and move these
> to the core header so existing x86 arch code continues to use them.
>
> Signed-off-by: James Morse <james.morse@....com>
> ---
> Changes since v3:
> * Restructure the existing macros instead of open-coding the for loop.
>
> Changes since v1:
> * [Whitespace only] Fix bogus whitespace introduced in
> rdtgroup_create_info_dir().
>
> * [Commit message only] Typo fix:
> s/architectures/architecture's/g
> ---
> arch/x86/kernel/cpu/resctrl/internal.h | 29 --------------------------
> include/linux/resctrl.h | 18 ++++++++++++++++
> 2 files changed, 18 insertions(+), 29 deletions(-)
>
> diff --git a/arch/x86/kernel/cpu/resctrl/internal.h
> b/arch/x86/kernel/cpu/resctrl/internal.h
> index 8e52e81a044b..84e0d019423d 100644
> --- a/arch/x86/kernel/cpu/resctrl/internal.h
> +++ b/arch/x86/kernel/cpu/resctrl/internal.h
> @@ -472,14 +472,6 @@ extern struct rdt_hw_resource rdt_resources_all[];
> extern struct rdtgroup rdtgroup_default; extern struct dentry
> *debugfs_resctrl;
>
> -static inline struct rdt_resource *resctrl_inc(struct rdt_resource *res) -{
> - struct rdt_hw_resource *hw_res = resctrl_to_arch_res(res);
> -
> - hw_res++;
> - return &hw_res->r_resctrl;
> -}
> -
> static inline bool resctrl_arch_get_cdp_enabled(enum resctrl_res_level l) {
> return rdt_resources_all[l].cdp_enabled; @@ -489,27 +481,6 @@ int
> resctrl_arch_set_cdp_enabled(enum resctrl_res_level l, bool enable);
>
> void arch_mon_domain_online(struct rdt_resource *r, struct rdt_mon_domain
> *d);
>
> -/*
> - * To return the common struct rdt_resource, which is contained in struct
> - * rdt_hw_resource, walk the resctrl member of struct rdt_hw_resource.
> - */
> -#define for_each_rdt_resource(r)
> \
> - for (r = &rdt_resources_all[0].r_resctrl; \
> - r <= &rdt_resources_all[RDT_NUM_RESOURCES - 1].r_resctrl;
> \
> - r = resctrl_inc(r))
> -
> -#define for_each_capable_rdt_resource(r)
> \
> - for_each_rdt_resource(r) \
> - if (r->alloc_capable || r->mon_capable)
> -
> -#define for_each_alloc_capable_rdt_resource(r)
> \
> - for_each_rdt_resource(r) \
> - if (r->alloc_capable)
> -
> -#define for_each_mon_capable_rdt_resource(r)
> \
> - for_each_rdt_resource(r) \
> - if (r->mon_capable)
> -
> /* CPUID.(EAX=10H, ECX=ResID=1).EAX */
> union cpuid_0x10_1_eax {
> struct {
> diff --git a/include/linux/resctrl.h b/include/linux/resctrl.h index
> c8cd6dde91ed..04a410a5e739 100644
> --- a/include/linux/resctrl.h
> +++ b/include/linux/resctrl.h
> @@ -26,6 +26,24 @@ int proc_resctrl_show(struct seq_file *m,
> /* max value for struct rdt_domain's mbps_val */
> #define MBA_MAX_MBPS U32_MAX
>
> +/* Walk all possible resources, with variants for only controls or monitors. */
> +#define for_each_rdt_resource(_r)
> \
> + for ((_r) = resctrl_arch_get_resource(0); \
> + (_r)->rid < RDT_NUM_RESOURCES - 1;
> \
> + (_r) = resctrl_arch_get_resource((_r)->rid + 1))
> +
> +#define for_each_capable_rdt_resource(r)
> \
> + for_each_rdt_resource((r))
> \
> + if ((r)->alloc_capable || (r)->mon_capable)
> +
> +#define for_each_alloc_capable_rdt_resource(r)
> \
> + for_each_rdt_resource((r))
> \
> + if ((r)->alloc_capable)
> +
> +#define for_each_mon_capable_rdt_resource(r)
> \
> + for_each_rdt_resource((r))
> \
> + if ((r)->mon_capable)
> +
ERROR: Macros with complex values should be enclosed in parentheses
Best regards,
Shaopeng TAN
Powered by blists - more mailing lists