lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20240821174022.63ca2c6a@p-imbrenda.boeblingen.de.ibm.com>
Date: Wed, 21 Aug 2024 17:40:22 +0200
From: Claudio Imbrenda <imbrenda@...ux.ibm.com>
To: Hariharan Mari <hari55@...ux.ibm.com>
Cc: linux-kselftest@...r.kernel.org, linux-kernel@...r.kernel.org,
        kvm@...r.kernel.org, shuah@...nel.org, frankja@...ux.ibm.com,
        borntraeger@...ux.ibm.com, david@...hat.com, pbonzini@...hat.com,
        schlameuss@...ux.ibm.com
Subject: Re: [PATCH v2 5/5] KVM: s390: selftests: Add regression tests for
 PLO subfunctions

On Tue, 20 Aug 2024 08:48:37 +0200
Hariharan Mari <hari55@...ux.ibm.com> wrote:

> Extend the existing regression test framework for s390x CPU subfunctions
> to include tests for the Perform Locked Operation (PLO) subfunction
> functions.
> 
> PLO was introduced in the very first 64-bit machine generation.
> Hence it is assumed PLO is always installed in the Z Arch.
> The test procedure follows the established pattern.
> 
> Suggested-by: Janosch Frank <frankja@...ux.ibm.com>
> Signed-off-by: Hariharan Mari <hari55@...ux.ibm.com>
> Reviewed-by: Janosch Frank <frankja@...ux.ibm.com>
> ---
>  .../kvm/s390x/cpumodel_subfuncs_test.c        | 34 +++++++++++++++++++
>  1 file changed, 34 insertions(+)
> 
> diff --git a/tools/testing/selftests/kvm/s390x/cpumodel_subfuncs_test.c b/tools/testing/selftests/kvm/s390x/cpumodel_subfuncs_test.c
> index c31f445c6f03..255984a52365 100644
> --- a/tools/testing/selftests/kvm/s390x/cpumodel_subfuncs_test.c
> +++ b/tools/testing/selftests/kvm/s390x/cpumodel_subfuncs_test.c
> @@ -20,6 +20,8 @@
>  
>  #include "kvm_util.h"
>  
> +#define U8_MAX  ((u8)~0U)

a more descriptive macro name would be better, maybe something like:

#define PLO_MAX_PARAMETER 255

the current macro is not much better than having just a magic number :)

> +
>  /**
>   * Query available CPU subfunctions
>   */
> @@ -37,6 +39,33 @@ static void get_cpu_machine_subfuntions(struct kvm_vm *vm,
>  	TEST_ASSERT(!r, "Get cpu subfunctions failed r=%d errno=%d", r, errno);
>  }
>  
> +static inline int plo_test_bit(unsigned char nr)
> +{
> +	unsigned long function = (unsigned long)nr | 0x100;

I think the (unsigned long) cast is not needed

> +	int cc;
> +
> +	asm volatile("	lgr	0,%[function]\n"
> +			/* Parameter registers are ignored for "test bit" */
> +			"	plo	0,0,0,0(0)\n"
> +			"	ipm	%0\n"
> +			"	srl	%0,28\n"
> +			: "=d" (cc)
> +			: [function] "d" (function)
> +			: "cc", "0");
> +	return cc == 0;
> +}
> +
> +/*
> + * Testing Perform Locked Operation (PLO) CPU subfunction's ASM block
> + */
> +static void test_plo_asm_block(u8 (*query)[32])
> +{
> +	for (int i = 0; i <= U8_MAX; ++i) {
> +		if (plo_test_bit(i))
> +			(*query)[i >> 3] |= 0x80 >> (i & 7);
> +	}
> +}
> +
>  /*
>   * Testing Crypto Compute Message Authentication Code (KMAC) CPU subfunction's
>   * ASM block
> @@ -237,6 +266,11 @@ struct testdef {
>  	testfunc_t test;
>  	int facility_bit;
>  } testlist[] = {
> +	/*  PLO was introduced in the very first 64-bit machine generation.

multi-line comments should not have text in the opening line 

> +	 *  Hence it is assumed PLO is always installed in Z Arch .
> +	 */
> +	{ "PLO", cpu_subfunc.plo, sizeof(cpu_subfunc.plo),
> +		test_plo_asm_block, 1 },
>  	/* MSA - Facility bit 17 */
>  	{ "KMAC", cpu_subfunc.kmac, sizeof(cpu_subfunc.kmac),
>  		test_kmac_asm_block, 17 },


Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ