[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <cover.1724225528.git.dsimic@manjaro.org>
Date: Wed, 21 Aug 2024 09:37:52 +0200
From: Dragan Simic <dsimic@...jaro.org>
To: linux-rockchip@...ts.infradead.org,
linux-phy@...ts.infradead.org
Cc: vkoul@...nel.org,
kishon@...nel.org,
heiko@...ech.de,
linux-arm-kernel@...ts.infradead.org,
linux-kernel@...r.kernel.org
Subject: [PATCH v2 0/3] Improve error handling in Rockchip Inno USB 2.0 PHY driver
This is a small series that improves error handling in the probe path
of the Rockchip Innosilicon USB 2.0 PHY driver, by returning the actual
error code in one place and by using dev_err_probe() properly in multiple
places. It also performs a bunch of small, rather trivial code cleanups,
to make the code neater and a bit easier to read.
Changes in v2:
- Expanded into a small series, after a suggestion from Heiko [1] to
use dev_err_probe(), because it all happens in the probe path
Link to v1: https://lore.kernel.org/linux-phy/5fa7796d71e2f46344e972bc98a54539f55b6109.1723551599.git.dsimic@manjaro.org/T/#u
[1] https://lore.kernel.org/linux-phy/4927264.xgNZFEDtJV@diego/
Dragan Simic (3):
phy: phy-rockchip-inno-usb2: Perform trivial code cleanups
phy: phy-rockchip-inno-usb2: Handle failed extcon allocation better
phy: phy-rockchip-inno-usb2: Improve error handling while probing
drivers/phy/rockchip/phy-rockchip-inno-usb2.c | 63 ++++++++-----------
1 file changed, 25 insertions(+), 38 deletions(-)
Powered by blists - more mailing lists