lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1abae895-7fb4-0342-21b9-1fd8e085dc9a@redhat.com>
Date: Thu, 22 Aug 2024 19:08:34 +0200 (CEST)
From: Mikulas Patocka <mpatocka@...hat.com>
To: Chen Yufan <chenyufan@...o.com>
cc: Alasdair Kergon <agk@...hat.com>, Mike Snitzer <snitzer@...nel.org>, 
    dm-devel@...ts.linux.dev, linux-kernel@...r.kernel.org, 
    opensource.kernel@...o.com
Subject: Re: [PATCH v1] Device-mapper(LVM): Convert to use time_after_eq
 macro



On Thu, 22 Aug 2024, Chen Yufan wrote:

> Use time_after_eq macro instead of opening it for readability.
> 
> Signed-off-by: Chen Yufan <chenyufan@...o.com>
> ---
>  drivers/md/dm-writecache.c | 5 +++--
>  1 file changed, 3 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/md/dm-writecache.c b/drivers/md/dm-writecache.c
> index 7ce8847b3..548d4d37e 100644
> --- a/drivers/md/dm-writecache.c
> +++ b/drivers/md/dm-writecache.c
> @@ -16,6 +16,7 @@
>  #include <linux/pfn_t.h>
>  #include <linux/libnvdimm.h>
>  #include <linux/delay.h>
> +#include <linux/jiffies.h>
>  #include "dm-io-tracker.h"
>  
>  #define DM_MSG_PREFIX "writecache"
> @@ -1994,8 +1995,8 @@ static void writecache_writeback(struct work_struct *work)
>  	while (!list_empty(&wc->lru) &&
>  	       (wc->writeback_all ||
>  		wc->freelist_size + wc->writeback_size <= wc->freelist_low_watermark ||
> -		(jiffies - container_of(wc->lru.prev, struct wc_entry, lru)->age >=
> -		 wc->max_age - wc->max_age / MAX_AGE_DIV))) {
> +		(time_after_eq(jiffies, container_of(wc->lru.prev, struct wc_entry, lru)->age +
> +		 (wc->max_age - wc->max_age / MAX_AGE_DIV))))) {
>  
>  		n_walked++;
>  		if (unlikely(n_walked > WRITEBACK_LATENCY) &&
> -- 
> 2.39.0

I'm not sure about this. The old and new code is not really equivalent.

Mikulas


Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ