[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <699b9d24-97bc-41c8-82c9-3bed34b18be8@redhat.com>
Date: Fri, 23 Aug 2024 17:27:18 +0200
From: Jocelyn Falempe <jfalempe@...hat.com>
To: Maarten Lankhorst <maarten.lankhorst@...ux.intel.com>,
Maxime Ripard <mripard@...nel.org>, Thomas Zimmermann <tzimmermann@...e.de>,
David Airlie <airlied@...il.com>, Daniel Vetter <daniel@...ll.ch>,
Miguel Ojeda <ojeda@...nel.org>, Alex Gaynor <alex.gaynor@...il.com>,
Wedson Almeida Filho <wedsonaf@...il.com>, Boqun Feng
<boqun.feng@...il.com>, Gary Guo <gary@...yguo.net>,
Bjorn Roy Baron <bjorn3_gh@...tonmail.com>,
Benno Lossin <benno.lossin@...ton.me>,
Andreas Hindborg <a.hindborg@...sung.com>, Alice Ryhl
<aliceryhl@...gle.com>, linux-kernel@...r.kernel.org,
dri-devel@...ts.freedesktop.org, rust-for-linux@...r.kernel.org,
Danilo Krummrich <dakr@...hat.com>
Subject: Re: [PATCH v7 0/4] drm/panic: Add a QR code panic screen
On 22/08/2024 09:33, Jocelyn Falempe wrote:
> This series adds a new panic screen, with the kmsg data embedded in a QR code.
>
> The main advantage of QR code, is that you can copy/paste the debug data to a bug report.
>
> The QR code encoder is written in rust, and is very specific to drm panic.
> The reason is that it is called in a panic handler, and thus can't allocate memory, or use locking.
> The rust code uses a few rust core API, and provides only two C entry points.
> There is no particular reason to do it in rust, I just wanted to learn rust, and see if it can work in the kernel.
>
> If you want to see what it looks like, I've put a few screenshots here:
> https://github.com/kdj0c/panic_report/issues/1
I just pushed it to drm-misc-next
Thank you all for your reviews.
Best regards,
--
Jocelyn
>
> v2:
> * Rewrite the rust comments with Markdown (Alice Ryhl)
> * Mark drm_panic_qr_generate() as unsafe (Alice Ryhl)
> * Use CStr directly, and remove the call to as_str_unchecked()
> (Alice Ryhl)
> * Add a check for data_len <= data_size (Greg KH)
>
> v3:
> * Fix all rust comments (typo, punctuation) (Miguel Ojeda)
> * Change the wording of safety comments (Alice Ryhl)
> * Add a link to the javascript decoder in the Kconfig (Greg KH)
> * Fix data_size and tmp_size check in drm_panic_qr_generate()
>
> v4:
> * Fix the logic to find next line and skip the '\n' (Alic Ryhl)
> * Remove __LOG_PREFIX as it's not used (Alice Ryhl)
>
> v5:
> * Move drm_panic_[init|exit]() prototype to drm_crtc_internal.h
> (Daniel Vetter)
>
> v6:
> * rebase, and handle conflict with 5d45c01dea6f ("drm/panic: Add panic description")
> * Fix qr_width should be a signed int, to handle error code.
>
> v7:
> * rename r1/r2 to a/b in drm_rect_overlap() (Jani Nikula)
>
> Jocelyn Falempe (4):
> drm/panic: Add integer scaling to blit()
> drm/rect: Add drm_rect_overlap()
> drm/panic: Simplify logo handling
> drm/panic: Add a QR code panic screen
>
> drivers/gpu/drm/Kconfig | 31 +
> drivers/gpu/drm/Makefile | 1 +
> drivers/gpu/drm/drm_crtc_internal.h | 4 +
> drivers/gpu/drm/drm_drv.c | 3 +
> drivers/gpu/drm/drm_panic.c | 340 +++++++--
> drivers/gpu/drm/drm_panic_qr.rs | 1003 +++++++++++++++++++++++++++
> include/drm/drm_rect.h | 15 +
> 7 files changed, 1357 insertions(+), 40 deletions(-)
> create mode 100644 drivers/gpu/drm/drm_panic_qr.rs
>
>
> base-commit: 04b5b362bc2a36f1dfe5cad52c83b1ea9d25b87c
Powered by blists - more mailing lists