[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20240826185213.9445-2-masingh.linux@gmail.com>
Date: Tue, 27 Aug 2024 00:22:13 +0530
From: Manisha Singh <masingh.linux@...il.com>
To: florian.c.schilhabel@...glemail.com,
gregkh@...uxfoundation.org,
linux-staging@...ts.linux.dev,
linux-kernel@...r.kernel.org
Cc: Manisha Singh <masingh.linux@...il.com>
Subject: [PATCH] staging: rtl8712: Fix style issues in rtl871x_io.c
This patch addresses style issues reported by checkpatch.pl in
drivers/staging/rtl8712/rtl871x_io.c:
1. Avoid Multiple Assignments: The original line had multiple
assignments in a single statement. This is generally discouraged
for clarity and maintainability. The code has been refactored to
use separate statements for each assignment.
2. Prefer `sizeof(*pintf_hdl->pintfpriv)` Over
`sizeof(struct intf_priv)`: Updated the memory allocation call to
use `sizeof(*pintf_hdl->pintfpriv)` instead of
`sizeof(struct intf_priv)`. This is considered better practice as it
automatically adjusts if the type of `pintf_hdl->pintfpriv` changes,
reducing the risk of mismatches and improving maintainability.
Changes made:
- Replaced the original line with two separate lines for allocation and
assignment.
- Updated `kmalloc` to use `sizeof(*pintf_hdl->pintfpriv)` for the
allocation size.
These changes improve code readability and maintain consistency with
coding standards.
Signed-off-by: Manisha Singh <masingh.linux@...il.com>
---
drivers/staging/rtl8712/rtl871x_io.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8712/rtl871x_io.c b/drivers/staging/rtl8712/rtl871x_io.c
index 6789a4c98564..b81e9b06725c 100644
--- a/drivers/staging/rtl8712/rtl871x_io.c
+++ b/drivers/staging/rtl8712/rtl871x_io.c
@@ -48,8 +48,8 @@ static uint _init_intf_hdl(struct _adapter *padapter,
set_intf_funs = &(r8712_usb_set_intf_funs);
set_intf_ops = &r8712_usb_set_intf_ops;
init_intf_priv = &r8712_usb_init_intf_priv;
- pintf_priv = pintf_hdl->pintfpriv = kmalloc(sizeof(struct intf_priv),
- GFP_ATOMIC);
+ pintf_priv = kmalloc(sizeof(*pintf_hdl->pintfpriv), GFP_ATOMIC);
+ pintf_hdl->pintfpriv = pintf_priv;
if (!pintf_priv)
goto _init_intf_hdl_fail;
pintf_hdl->adapter = (u8 *)padapter;
--
2.43.0
Powered by blists - more mailing lists