lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20240828205128.92145-1-vassilisamir@gmail.com>
Date: Wed, 28 Aug 2024 22:51:20 +0200
From: Vasileios Amoiridis <vassilisamir@...il.com>
To: jic23@...nel.org,
	lars@...afoo.de,
	robh@...nel.org,
	krzk+dt@...nel.org,
	conor+dt@...nel.org,
	andriy.shevchenko@...ux.intel.com
Cc: vassilisamir@...il.com,
	ang.iglesiasg@...il.com,
	linus.walleij@...aro.org,
	biju.das.jz@...renesas.com,
	javier.carrasco.cruz@...il.com,
	semen.protsenko@...aro.org,
	579lpy@...il.com,
	ak@...klinger.de,
	linux-iio@...r.kernel.org,
	devicetree@...r.kernel.org,
	linux-kernel@...r.kernel.org,
	christophe.jaillet@...adoo.fr
Subject: [PATCH v4 0/7] pressure: bmp280: Minor cleanup and interrupt support

Depends on this: https://lore.kernel.org/linux-iio/20240823172017.9028-1-vassilisamir@gmail.com

Changes in v4:

[PATCH v4 1/7]:
	- Use better names and split value assignments for better readability.

[PATCH v4 2/7]:
	- Move to fsleep() and add comment on top
	- Use appropriate return error value in bmp280_preinit()

[PATCH v4 3/7]:
	- Split lines for logical and better readability

[PATCH v4 4/7]:
	- Change style in static const array assignments
	- Use BIT() function instead of bit shifting
	- Change usleep_range() to fsleep() and add comments

[PATCH v4 5/7]:
	- Add allOf:if in order to allow the interrupt in the device-tree
	  only in sensors who support it.

[PATCH v4 6/7]:
	- Change function pointer return type to irq_handler_t
	- Remove extra check in dev_fwnode()
	- Fix check in fwnode_irq_get()
	- Fix shadowed error check
	- Remove extra check in irq_get_irq_data(irq);
	- Improve indentation
	- Fix return values in certain cases
	- Fix identation and if checks

[PATCH v4 7/7]:
	- Fix commit message

Vasileios Amoiridis (7):
  iio: pressure: bmp280: Use bulk read for humidity calibration data
  iio: pressure: bmp280: Add support for bmp280 soft reset
  iio: pressure: bmp280: Remove config error check for IIR filter
    updates
  iio: pressure: bmp280: Use sleep and forced mode for oneshot captures
  dt-bindings: iio: pressure: bmp085: Add interrupts for BMP3xx and
    BMP5xx devices
  iio: pressure: bmp280: Add data ready trigger support
  iio: pressure: bmp280: Move bmp085 interrupt to new configuration

 .../bindings/iio/pressure/bmp085.yaml         |  22 +-
 drivers/iio/pressure/bmp280-core.c            | 692 +++++++++++++++---
 drivers/iio/pressure/bmp280-i2c.c             |   4 +-
 drivers/iio/pressure/bmp280-spi.c             |   4 +-
 drivers/iio/pressure/bmp280.h                 |  52 ++
 5 files changed, 684 insertions(+), 90 deletions(-)


base-commit: 0f718e10da81446df0909c9939dff2b77e3b4e95
prerequisite-patch-id: e4f81f31f4fbb2aa872c0c74ed4511893eee0c9a
-- 
2.25.1


Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ