[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-id: <172482240148.4433.18164936555410000141@noble.neil.brown.name>
Date: Wed, 28 Aug 2024 15:20:01 +1000
From: "NeilBrown" <neilb@...e.de>
To: "Dave Chinner" <david@...morbit.com>
Cc: "Ingo Molnar" <mingo@...hat.com>, "Peter Zijlstra" <peterz@...radead.org>,
"Linus Torvalds" <torvalds@...ux-foundation.org>,
linux-kernel@...r.kernel.org, linux-fsdevel@...r.kernel.org
Subject:
Re: [PATCH 5/9] Block: switch bd_prepare_to_claim to use ___wait_var_event()
On Wed, 28 Aug 2024, Dave Chinner wrote:
> On Wed, Aug 21, 2024 at 07:52:39AM +1000, NeilBrown wrote:
> > On Tue, 20 Aug 2024, Dave Chinner wrote:
> > > On Mon, Aug 19, 2024 at 03:20:39PM +1000, NeilBrown wrote:
> > > > bd_prepare_to_claim() current uses a bit waitqueue with a matching
> > > > wake_up_bit() in bd_clear_claiming(). However it is really waiting on a
> > > > "var", not a "bit".
> > > >
> > > > So change to wake_up_var(), and use ___wait_var_event() for the waiting.
> > > > Using the triple-underscore version allows us to drop the mutex across
> > > > the schedule() call.
> > > ....
> > > > @@ -535,33 +535,23 @@ int bd_prepare_to_claim(struct block_device *bdev, void *holder,
> > > > const struct blk_holder_ops *hops)
> > > > {
> > > > struct block_device *whole = bdev_whole(bdev);
> > > > + int err = 0;
> > > >
> > > > if (WARN_ON_ONCE(!holder))
> > > > return -EINVAL;
> > > > -retry:
> > > > - mutex_lock(&bdev_lock);
> > > > - /* if someone else claimed, fail */
> > > > - if (!bd_may_claim(bdev, holder, hops)) {
> > > > - mutex_unlock(&bdev_lock);
> > > > - return -EBUSY;
> > > > - }
> > > > -
> > > > - /* if claiming is already in progress, wait for it to finish */
> > > > - if (whole->bd_claiming) {
> > > > - wait_queue_head_t *wq = bit_waitqueue(&whole->bd_claiming, 0);
> > > > - DEFINE_WAIT(wait);
> > > >
> > > > - prepare_to_wait(wq, &wait, TASK_UNINTERRUPTIBLE);
> > > > - mutex_unlock(&bdev_lock);
> > > > - schedule();
> > > > - finish_wait(wq, &wait);
> > > > - goto retry;
> > > > - }
> > > > + mutex_lock(&bdev_lock);
> > > > + ___wait_var_event(&whole->bd_claiming,
> > > > + (err = bd_may_claim(bdev, holder, hops)) != 0 || !whole->bd_claiming,
> > > > + TASK_UNINTERRUPTIBLE, 0, 0,
> > > > + mutex_unlock(&bdev_lock); schedule(); mutex_lock(&bdev_lock));
> > >
> > > That's not an improvement. Instead of nice, obvious, readable code,
> > > I now have to go look at a macro and manually substitute the
> > > parameters to work out what this abomination actually does.
> >
> > Interesting - I thought the function as a whole was more readable this
> > way.
> > I agree that the ___wait_var_event macro isn't the best part.
> > Is your dislike simply that it isn't a macro that you are familar with,
> > or is there something specific that you don't like?
>
> It's the encoding of non-trivial logic and code into the macro
> parameters that is the problem....
It would probably make sense to move all the logic into bd_may_claim()
so that it returns:
-EBUSY if claim cannot succeed
-EAGAIN if claim might succeed soon, or
0 if it can be claimed now.
Then the wait becomes:
wait_var_event_mutex(&whole->bd_claiming,
bd_may_claim(bdev, holder, hops) != -EAGAIN,
&bdev_lock);
>
> > Suppose we could add a new macro so that it read:
> >
> > wait_var_event_mutex(&whole->bd_claiming,
> > (err = bd_may_claim(bdev, holder, hops)) != 0 || !whole->bd_claiming,
> > &bdev_lock);
>
> .... and this still does it.
>
> In fact, it's worse, because now I have -zero idea- of what locking
> is being performed in this case, and so now I definitely have to go
> pull that macro apart to understand what this is actually doing.
>
> Complex macros don't make understanding the code easier - they may
> make writing the code faster, but that comes at the expense of
> clarity and obviousness of the logic flow of the code...
I think that SIMPLE macros rarely make the code easier to understand -
for precisely the reason that you have to go and find out what the macro
actually does.
Complex macros obviously suffer the same problem but I believe they
bring tangible benefits by making review easier for those who understand
the macros, and consequently reducing bugs.
I'm currently particularly sensitive to this since finding that the
open-coded wait loop in pkt_make_request_write() - which I wrote - is
missing a finish_wait() call. Ouch. If there had been a
wait_var_event_spinlock() when I wrote that code, the mistake would not
have happened.
The argument about locking being non-obvious is, I think, doubly true
for wait_on_bit_lock(). But that is still a useful interface.
Thanks,
NeilBrown
Powered by blists - more mailing lists