[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID:
<TY0PR06MB49846789A7ED4370E825BB0F85952@TY0PR06MB4984.apcprd06.prod.outlook.com>
Date: Wed, 28 Aug 2024 02:11:10 +0000
From: Angus Chen <angus.chen@...uarmicro.com>
To: Greg KH <gregkh@...uxfoundation.org>
CC: "rafael@...nel.org" <rafael@...nel.org>, "linux-kernel@...r.kernel.org"
<linux-kernel@...r.kernel.org>
Subject: RE: [PATCH] drivers: core: Add more print info for bus remove and
driver remove
Hi,gregkh.
> -----Original Message-----
> From: Greg KH <gregkh@...uxfoundation.org>
> Sent: Tuesday, August 27, 2024 9:19 PM
> To: Angus Chen <angus.chen@...uarmicro.com>
> Cc: rafael@...nel.org; linux-kernel@...r.kernel.org
> Subject: Re: [PATCH] drivers: core: Add more print info for bus remove and driver
> remove
>
> On Tue, Aug 27, 2024 at 08:52:44PM +0800, Angus Chen wrote:
> > When enable initcall_debug,some devices call bus remove,
> > Some devices call driver remove.
> >
> > Signed-off-by: Angus Chen <angus.chen@...uarmicro.com>
> > ---
> > drivers/base/core.c | 4 ++--
> > 1 file changed, 2 insertions(+), 2 deletions(-)
> >
> > diff --git a/drivers/base/core.c b/drivers/base/core.c
> > index 8c0733d3aad8..ff965cd51bcf 100644
> > --- a/drivers/base/core.c
> > +++ b/drivers/base/core.c
> > @@ -4833,11 +4833,11 @@ void device_shutdown(void)
> > }
> > if (dev->bus && dev->bus->shutdown) {
> > if (initcall_debug)
> > - dev_info(dev, "shutdown\n");
> > + dev_info(dev, "call bus shutdown\n");
> > dev->bus->shutdown(dev);
> > } else if (dev->driver && dev->driver->shutdown) {
> > if (initcall_debug)
> > - dev_info(dev, "shutdown\n");
> > + dev_info(dev, "call driver shutdown\n");
>
> I do not understand, why is this needed? Who needs it and what is going
> to rely on it?
Thank you for your reply.
While I'm troubleshooting the shutdown sequence of my own bus, I get the same print of the
Different devices. Because some bus->shutdown call the drv->shutdown first, so I want to
Make different print info to differentiate it.
>
> Really, this should be moved to dev_dbg() instead, right?
You are right, dev_dbg looks more better . should I take this patch together or just change it
To dev_dbg?
>
> thanks,
>
> greg k-h
Powered by blists - more mailing lists