[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <0c76ca65-acc1-4167-b2ca-d6d7ef0b5c64@gmail.com>
Date: Thu, 29 Aug 2024 07:37:42 +0200
From: Philipp Hortmann <philipp.g.hortmann@...il.com>
To: Manisha Singh <masingh.linux@...il.com>,
florian.c.schilhabel@...glemail.com, gregkh@...uxfoundation.org,
linux-staging@...ts.linux.dev, linux-kernel@...r.kernel.org
Subject: Re: [PATCH v3 1/2] staging: rtl8712: Fix style issues in rtl871x_io.c
On 8/29/24 00:21, Manisha Singh wrote:
> Refactor the _init_intf_hdl() function to avoid multiple
> assignments in a single statement. This change improves code readability
> and adheres to kernel coding style guidelines.
>
> Signed-off-by: Manisha Singh <masingh.linux@...il.com>
> ---
> Changes since v2:
> - commit message updated.
> - assignment done before goto fail.
>
> Changes since v1:
> Broke the patch into 2 different fixes.
>
> drivers/staging/rtl8712/rtl871x_io.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/staging/rtl8712/rtl871x_io.c b/drivers/staging/rtl8712/rtl871x_io.c
> index 6789a4c98564..378da0aa7f55 100644
> --- a/drivers/staging/rtl8712/rtl871x_io.c
> +++ b/drivers/staging/rtl8712/rtl871x_io.c
> @@ -48,8 +48,8 @@ static uint _init_intf_hdl(struct _adapter *padapter,
> set_intf_funs = &(r8712_usb_set_intf_funs);
> set_intf_ops = &r8712_usb_set_intf_ops;
> init_intf_priv = &r8712_usb_init_intf_priv;
> - pintf_priv = pintf_hdl->pintfpriv = kmalloc(sizeof(struct intf_priv),
> - GFP_ATOMIC);
> + pintf_priv = kmalloc(sizeof(struct intf_priv), GFP_ATOMIC);
> + pintf_hdl->pintfpriv = pintf_priv;
> if (!pintf_priv)
> goto _init_intf_hdl_fail;
> pintf_hdl->adapter = (u8 *)padapter;
Tested-by: Philipp Hortmann <philipp.g.hortmann@...il.com> AW-NU120
Powered by blists - more mailing lists