[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <9de6ca8f-b3f1-4ebc-a5eb-185532e164e7@efficios.com>
Date: Mon, 2 Sep 2024 14:08:00 -0400
From: Mathieu Desnoyers <mathieu.desnoyers@...icios.com>
To: Peter Zijlstra <peterz@...radead.org>,
Linus Torvalds <torvalds@...ux-foundation.org>
Cc: Ingo Molnar <mingo@...hat.com>, linux-kernel@...r.kernel.org,
Kees Cook <keescook@...omium.org>, Greg KH <gregkh@...uxfoundation.org>,
Sean Christopherson <seanjc@...gle.com>, Steven Rostedt
<rostedt@...dmis.org>, Masami Hiramatsu <mhiramat@...nel.org>,
Alexei Starovoitov <ast@...nel.org>, Yonghong Song <yhs@...com>,
"Paul E . McKenney" <paulmck@...nel.org>,
Arnaldo Carvalho de Melo <acme@...nel.org>,
Mark Rutland <mark.rutland@....com>,
Alexander Shishkin <alexander.shishkin@...ux.intel.com>,
Namhyung Kim <namhyung@...nel.org>, bpf@...r.kernel.org,
Joel Fernandes <joel@...lfernandes.org>, linux-trace-kernel@...r.kernel.org,
Ingo Molnar <mingo@...nel.org>
Subject: Re: [PATCH v1 2/2] cleanup.h: Introduce DEFINE_INACTIVE_GUARD and
activate_guard
On 2024-09-02 11:43, Peter Zijlstra wrote:
> On Wed, Aug 28, 2024 at 10:37:19AM -0400, Mathieu Desnoyers wrote:
>> To cover scenarios where the scope of the guard differs from the scope
>> of its activation, introduce DEFINE_INACTIVE_GUARD() and activate_guard().
>>
>> Here is an example use for a conditionally activated guard variable:
>>
>> void func(bool a)
>> {
>> DEFINE_INACTIVE_GUARD(preempt_notrace, myguard);
>>
>> [...]
>> if (a) {
>> might_sleep();
>> activate_guard(preempt_notrace, myguard)();
>> }
>> [ protected code ]
>> }
>
> So... I more or less proposed this much earlier:
>
> https://lore.kernel.org/all/20230919131038.GC39346@noisy.programming.kicks-ass.net/T/#mb7b84212619ac743dfe4d2cc81decce451586b27
>
> and Linus took objection to similar patterns. But perhaps my naming
> wasn't right.
Then you suggested something like a "guard_if()":
https://lore.kernel.org/lkml/20231120221524.GD8262@noisy.programming.kicks-ass.net/
which I find really odd because it requires to evaluate the same
condition twice within the function if it is used as guard_if
expression and needed as expression within the rest of the function
flow. I find the original patch with labels and gotos less ugly
than the guard_if().
Hence my proposal to optionally separate the definition from the activation,
which nicely integrates with the existing code flow.
If Linus' objections were mainly about naming, perhaps what I am
suggestion here may be more to his liking ?
Thanks,
Mathieu
--
Mathieu Desnoyers
EfficiOS Inc.
https://www.efficios.com
Powered by blists - more mailing lists