[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20240902184222.24874-1-vassilisamir@gmail.com>
Date: Mon, 2 Sep 2024 20:42:15 +0200
From: Vasileios Amoiridis <vassilisamir@...il.com>
To: jic23@...nel.org,
lars@...afoo.de,
robh@...nel.org,
krzk+dt@...nel.org,
conor+dt@...nel.org,
andriy.shevchenko@...ux.intel.com
Cc: vassilisamir@...il.com,
ang.iglesiasg@...il.com,
linus.walleij@...aro.org,
biju.das.jz@...renesas.com,
javier.carrasco.cruz@...il.com,
semen.protsenko@...aro.org,
579lpy@...il.com,
ak@...klinger.de,
linux-iio@...r.kernel.org,
devicetree@...r.kernel.org,
linux-kernel@...r.kernel.org,
christophe.jaillet@...adoo.fr
Subject: [PATCH v5 0/7] pressure: bmp280: Minor cleanup and interrupt support
Depends on this: https://lore.kernel.org/linux-iio/20240823172017.9028-1-vassilisamir@gmail.com
Changes in v5:
[PATCH v5 1/7]:
- Use local variable instead of direct assignment to improve
readability
[PATCH v5 2/7]:
- Use local variable instead of direct assignment to improve
readability
[PATCH v5 4/7]:
- Improve commit message
- Use unit suffix in time variables
- Use local variable instead of direct assignment to improve
readability
- Use 8 elements per line in the const int array
[PATCH v5 5/7]:
- Use not in the allOf:int: to reduce if cases
- Use type:boolean
[PATCH v5 6/7]:
- Use local variable instead of direct assignment to improve
readability
- Use irq_get_trigger_type()
- Make return paths consistent
[PATCH v5 7/7]:
- Use local variable instead of direct assignment to improve
readbility
---
v4: https://lore.kernel.org/linux-iio/20240828205128.92145-1-vassilisamir@gmail.com
v3: https://lore.kernel.org/linux-iio/20240823181714.64545-1-vassilisamir@gmail.com
v2: https://lore.kernel.org/linux-iio/20240725231039.614536-1-vassilisamir@gmail.com
v1: https://lore.kernel.org/linux-iio/20240711211558.106327-1-vassilisamir@gmail.com
Vasileios Amoiridis (7):
iio: pressure: bmp280: Use bulk read for humidity calibration data
iio: pressure: bmp280: Add support for bmp280 soft reset
iio: pressure: bmp280: Remove config error check for IIR filter
updates
iio: pressure: bmp280: Use sleep and forced mode for oneshot captures
dt-bindings: iio: pressure: bmp085: Add interrupts for BMP3xx and
BMP5xx devices
iio: pressure: bmp280: Add data ready trigger support
iio: pressure: bmp280: Move bmp085 interrupt to new configuration
.../bindings/iio/pressure/bmp085.yaml | 22 +-
drivers/iio/pressure/bmp280-core.c | 682 +++++++++++++++---
drivers/iio/pressure/bmp280-i2c.c | 4 +-
drivers/iio/pressure/bmp280-spi.c | 4 +-
drivers/iio/pressure/bmp280.h | 52 ++
5 files changed, 675 insertions(+), 89 deletions(-)
base-commit: 0f718e10da81446df0909c9939dff2b77e3b4e95
prerequisite-patch-id: e4f81f31f4fbb2aa872c0c74ed4511893eee0c9a
--
2.25.1
Powered by blists - more mailing lists