[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <87v7z4gfi7.fsf@nvdebian.thelocal>
Date: Tue, 10 Sep 2024 16:57:41 +1000
From: Alistair Popple <apopple@...dia.com>
To: Matthew Wilcox <willy@...radead.org>
Cc: dan.j.williams@...el.com, linux-mm@...ck.org, vishal.l.verma@...el.com,
dave.jiang@...el.com, logang@...tatee.com, bhelgaas@...gle.com,
jack@...e.cz, jgg@...pe.ca, catalin.marinas@....com, will@...nel.org,
mpe@...erman.id.au, npiggin@...il.com, dave.hansen@...ux.intel.com,
ira.weiny@...el.com, djwong@...nel.org, tytso@....edu,
linmiaohe@...wei.com, david@...hat.com, peterx@...hat.com,
linux-doc@...r.kernel.org, linux-kernel@...r.kernel.org,
linux-arm-kernel@...ts.infradead.org, linuxppc-dev@...ts.ozlabs.org,
nvdimm@...ts.linux.dev, linux-cxl@...r.kernel.org,
linux-fsdevel@...r.kernel.org, linux-ext4@...r.kernel.org,
linux-xfs@...r.kernel.org, jhubbard@...dia.com, hch@....de,
david@...morbit.com, Jason Gunthorpe <jgg@...dia.com>
Subject: Re: [PATCH 04/12] mm: Allow compound zone device pages
Matthew Wilcox <willy@...radead.org> writes:
> On Tue, Sep 10, 2024 at 02:14:29PM +1000, Alistair Popple wrote:
>> @@ -337,6 +341,7 @@ struct folio {
>> /* private: */
>> };
>> /* public: */
>> + struct dev_pagemap *pgmap;
>
> Shouldn't that be indented by one more tab stop?
>
> And for ease of reading, perhaps it should be placed either immediately
> before or after 'struct list_head lru;'?
>
>> +++ b/include/linux/mmzone.h
>> @@ -1134,6 +1134,12 @@ static inline bool is_zone_device_page(const struct page *page)
>> return page_zonenum(page) == ZONE_DEVICE;
>> }
>>
>> +static inline struct dev_pagemap *page_dev_pagemap(const struct page *page)
>> +{
>> + WARN_ON(!is_zone_device_page(page));
>> + return page_folio(page)->pgmap;
>> +}
>
> I haven't read to the end yet, but presumably we'll eventually want:
>
> static inline struct dev_pagemap *folio_dev_pagemap(const struct folio *folio)
> {
> WARN_ON(!folio_is_zone_device(folio))
> return folio->pgmap;
> }
>
> and since we'll want it eventually, maybe now is the time to add it,
> and make page_dev_pagemap() simply call it?
Sounds reasonable. I had open-coded folio->pgmap where it's needed
because at those points it's "obviously" a ZONE_DEVICE folio. Will add
it.
Powered by blists - more mailing lists