[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20240912121609.13438-1-ramona.nechita@analog.com>
Date: Thu, 12 Sep 2024 15:15:44 +0300
From: Ramona Alexandra Nechita <ramona.nechita@...log.com>
To: Jonathan Cameron <jic23@...nel.org>, Lars-Peter Clausen <lars@...afoo.de>,
Cosmin Tanislav <cosmin.tanislav@...log.com>,
Michael Hennerich
<Michael.Hennerich@...log.com>,
Rob Herring <robh@...nel.org>,
"Krzysztof
Kozlowski" <krzk+dt@...nel.org>,
Conor Dooley <conor+dt@...nel.org>, Nuno Sa
<nuno.sa@...log.com>,
David Lechner <dlechner@...libre.com>,
Andy Shevchenko
<andy@...nel.org>,
Marcelo Schmitt <marcelo.schmitt@...log.com>,
"Olivier
Moysan" <olivier.moysan@...s.st.com>,
Dumitru Ceclan
<mitrutzceclan@...il.com>,
Matteo Martelli <matteomartelli3@...il.com>,
João Paulo Gonçalves <joao.goncalves@...adex.com>,
Alisa-Dariana Roman <alisadariana@...il.com>,
Ivan Mikhaylov
<fr0st61te@...il.com>,
AngeloGioacchino Del Regno
<angelogioacchino.delregno@...labora.com>,
Marius Cristea
<marius.cristea@...rochip.com>,
Ramona Nechita <ramona.nechita@...log.com>,
<linux-iio@...r.kernel.org>, <linux-kernel@...r.kernel.org>,
<devicetree@...r.kernel.org>
Subject: [PATCH v5 0/3] add support for ad777x family
v4:
* https://lore.kernel.org/all/20240724155517.12470-1-ramona.nechita@analog.com/
v5:
* Patch1:
- removed yaml unnecessary nodes
- removed vref_supply from yaml altogether, as it is not used by the driver
- documented interrupt line in yaml file
- updated commit message with short description
* Patch2:
- version downgrade in sysfs-bus-iio file due to combinig the two drivers'
attributes together (one was available in 6.1 and the other in 6.2 and it
seemed right to leave it as 6.1)
* Patch3:
- removed comments with old code
- fix commit messages
- removed power_mode from driver private structure
- used spi_write for ad7779_spi_write function
- fixed various indents and line wraps, typos etc
- used goto in trig_handler to get rid of duplicate code
- switched to iio_for_each_active_channel
- removed unnecessary trig setting (done by devm already)
- removed __maybe_unused from driver suspend/resume functions
Ramona Alexandra Nechita (3):
dt-bindings: iio: adc: add a7779 doc
Documentation: ABI: added filter mode doc in sysfs-bus-iio
drivers: iio: adc: add support for ad777x family
Documentation/ABI/testing/sysfs-bus-iio | 22 +
.../ABI/testing/sysfs-bus-iio-adc-ad4130 | 46 -
.../bindings/iio/adc/adi,ad7779.yaml | 84 ++
drivers/iio/adc/Kconfig | 11 +
drivers/iio/adc/Makefile | 1 +
drivers/iio/adc/ad7779.c | 917 ++++++++++++++++++
6 files changed, 1035 insertions(+), 46 deletions(-)
delete mode 100644 Documentation/ABI/testing/sysfs-bus-iio-adc-ad4130
create mode 100644 Documentation/devicetree/bindings/iio/adc/adi,ad7779.yaml
create mode 100644 drivers/iio/adc/ad7779.c
--
2.43.0
Powered by blists - more mailing lists