[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20240912131656.GC29641@lst.de>
Date: Thu, 12 Sep 2024 15:16:56 +0200
From: Christoph Hellwig <hch@....de>
To: John Garry <john.g.garry@...cle.com>
Cc: axboe@...nel.dk, song@...nel.org, yukuai3@...wei.com, kbusch@...nel.org,
hch@....de, sagi@...mberg.me, James.Bottomley@...senPartnership.com,
martin.petersen@...cle.com, linux-block@...r.kernel.org,
linux-kernel@...r.kernel.org, linux-raid@...r.kernel.org,
linux-nvme@...ts.infradead.org, linux-scsi@...r.kernel.org
Subject: Re: [PATCH RFC 3/4] block: Support atomic writes limits for
stacked devices
On Tue, Sep 03, 2024 at 03:07:47PM +0000, John Garry wrote:
> + } else if (t->features & BLK_FEAT_ATOMIC_WRITES) {
> + t->atomic_write_hw_max = min_not_zero(t->atomic_write_hw_max,
> + b->atomic_write_hw_max);
> + t->atomic_write_boundary_sectors =
> + min_not_zero(t->atomic_write_boundary_sectors,
> + b->atomic_write_boundary_sectors);
> + t->atomic_write_hw_unit_min = max(t->atomic_write_hw_unit_min,
> + b->atomic_write_hw_unit_min);
> + t->atomic_write_hw_unit_max =
> + min_not_zero(t->atomic_write_hw_unit_max,
> + b->atomic_write_hw_unit_max);
Maybe split this into a helper to make the code more readable?
Otherwise this looks good to me.
Powered by blists - more mailing lists