[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20240926135418.8342-1-ramona.nechita@analog.com>
Date: Thu, 26 Sep 2024 16:53:54 +0300
From: Ramona Alexandra Nechita <ramona.nechita@...log.com>
To: Jonathan Cameron <jic23@...nel.org>, Lars-Peter Clausen <lars@...afoo.de>,
Michael Hennerich <Michael.Hennerich@...log.com>,
Rob Herring
<robh@...nel.org>,
Krzysztof Kozlowski <krzk+dt@...nel.org>,
Conor Dooley
<conor+dt@...nel.org>, Nuno Sa <nuno.sa@...log.com>,
Andy Shevchenko
<andy@...nel.org>,
David Lechner <dlechner@...libre.com>,
Marcelo Schmitt
<marcelo.schmitt@...log.com>,
Olivier Moysan <olivier.moysan@...s.st.com>,
Dumitru Ceclan <mitrutzceclan@...il.com>,
Matteo Martelli
<matteomartelli3@...il.com>,
AngeloGioacchino Del Regno
<angelogioacchino.delregno@...labora.com>,
Alisa-Dariana Roman
<alisadariana@...il.com>,
João Paulo Gonçalves
<joao.goncalves@...adex.com>,
Marius Cristea <marius.cristea@...rochip.com>,
Ramona Nechita <ramona.nechita@...log.com>,
<linux-iio@...r.kernel.org>, <linux-kernel@...r.kernel.org>,
<devicetree@...r.kernel.org>
Subject: [PATCH v6 0/3] add support for ad777x family
v5:
* https://lore.kernel.org/all/20240912121609.13438-1-ramona.nechita@analog.com/
v6:
* Patch1:
- documented power supplies
- added interrupt names and description for ALERT & DRDY
* Patch2:
- removed the referenced file from MAINTAINERS
- updated the commit msg mentioning the version changed
* Patch3:
- added comments to explain formulas
- fixed typo in commit msg
- crc is no longer calculated when not used
- regval calculated in one line
- updated variable name kfreq -> freq_khz
- inserted blank lines for more readability
- created a structure for buffer data in the private structure and used
aligned _s64 for the timestamp
- presence of irq is checked first thing in the probe function to avoid
allocating resources for nothing
- initialized ret with -EINVAL in probe
- wrapped closer to 80 chars where it was possible
- removed check for buffer enabled due to redundancy
- restructured reset function to share the same fsleep whether or not gpio
is present, and to avoid redundant memset
Ramona Alexandra Nechita (3):
dt-bindings: iio: adc: add a7779 doc
Documentation: ABI: added filter mode doc in sysfs-bus-iio
drivers: iio: adc: add support for ad777x family
Documentation/ABI/testing/sysfs-bus-iio | 22 +
.../ABI/testing/sysfs-bus-iio-adc-ad4130 | 46 -
.../bindings/iio/adc/adi,ad7779.yaml | 108 +++
MAINTAINERS | 1 -
drivers/iio/adc/Kconfig | 11 +
drivers/iio/adc/Makefile | 1 +
drivers/iio/adc/ad7779.c | 911 ++++++++++++++++++
7 files changed, 1053 insertions(+), 47 deletions(-)
delete mode 100644 Documentation/ABI/testing/sysfs-bus-iio-adc-ad4130
create mode 100644 Documentation/devicetree/bindings/iio/adc/adi,ad7779.yaml
create mode 100644 drivers/iio/adc/ad7779.c
--
2.43.0
Powered by blists - more mailing lists