[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <427950dc-1bc3-42b4-aa63-ffa0d197a00b@suse.cz>
Date: Tue, 1 Oct 2024 18:31:26 +0200
From: Vlastimil Babka <vbabka@...e.cz>
To: "Uladzislau Rezki (Sony)" <urezki@...il.com>
Cc: "Paul E . McKenney" <paulmck@...nel.org>, RCU <rcu@...r.kernel.org>,
LKML <linux-kernel@...r.kernel.org>,
Neeraj upadhyay <Neeraj.Upadhyay@....com>, Boqun Feng
<boqun.feng@...il.com>, Joel Fernandes <joel@...lfernandes.org>,
Frederic Weisbecker <frederic@...nel.org>,
Oleksiy Avramchenko <oleksiy.avramchenko@...y.com>,
Linus Torvalds <torvalds@...ux-foundation.org>
Subject: Re: [PATCH] rcu/kvfree: Refactor kvfree_rcu_queue_batch()
On 9/30/24 13:37, Uladzislau Rezki (Sony) wrote:
> Improve readability of kvfree_rcu_queue_batch() function
> in away that, after a first batch queuing, the loop is break
> and success value is returned to a caller.
>
> There is no reason to loop and check batches further as all
> outstanding objects have already been picked and attached to
> a certain batch to complete an offloading.
>
> Link: https://lore.kernel.org/lkml/ZvWUt2oyXRsvJRNc@pc636/T/
> Suggested-by: Linus Torvalds <torvalds@...ux-foundation.org>
> Signed-off-by: Uladzislau Rezki (Sony) <urezki@...il.com>
Applied to slab/for-next, thanks!
> ---
> kernel/rcu/tree.c | 9 +++++----
> 1 file changed, 5 insertions(+), 4 deletions(-)
>
> diff --git a/kernel/rcu/tree.c b/kernel/rcu/tree.c
> index a60616e69b66..b1f883fcd918 100644
> --- a/kernel/rcu/tree.c
> +++ b/kernel/rcu/tree.c
> @@ -3607,11 +3607,12 @@ kvfree_rcu_queue_batch(struct kfree_rcu_cpu *krcp)
> }
>
> // One work is per one batch, so there are three
> - // "free channels", the batch can handle. It can
> - // be that the work is in the pending state when
> - // channels have been detached following by each
> - // other.
> + // "free channels", the batch can handle. Break
> + // the loop since it is done with this CPU thus
> + // queuing an RCU work is _always_ success here.
> queued = queue_rcu_work(system_unbound_wq, &krwp->rcu_work);
> + WARN_ON_ONCE(!queued);
> + break;
> }
> }
>
Powered by blists - more mailing lists