lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <aa573189-e42d-4d62-84a3-dda9fbed0b33@proton.me>
Date: Fri, 04 Oct 2024 08:58:18 +0000
From: Benno Lossin <benno.lossin@...ton.me>
To: Thomas Gleixner <tglx@...utronix.de>, Lyude Paul <lyude@...hat.com>, rust-for-linux@...r.kernel.org
Cc: Danilo Krummrich <dakr@...hat.com>, airlied@...hat.com, Ingo Molnar <mingo@...hat.com>, Will Deacon <will@...nel.org>, Waiman Long <longman@...hat.com>, Peter Zijlstra <peterz@...radead.org>, linux-kernel@...r.kernel.org, Daniel Almeida <daniel.almeida@...labora.com>, Gary Guo <gary@...yguo.net>, Miguel Ojeda <ojeda@...nel.org>, Alex Gaynor <alex.gaynor@...il.com>, Wedson Almeida Filho <wedsonaf@...il.com>, Boqun Feng <boqun.feng@...il.com>, Björn Roy Baron <bjorn3_gh@...tonmail.com>, Andreas Hindborg <a.hindborg@...sung.com>, Alice Ryhl <aliceryhl@...gle.com>, Trevor Gross <tmgross@...ch.edu>, FUJITA Tomonori <fujita.tomonori@...il.com>, Valentin Obst <kernel@...entinobst.de>
Subject: Re: [PATCH v6 1/3] rust: Introduce irq module

On 02.10.24 22:20, Thomas Gleixner wrote:
> On Mon, Sep 16 2024 at 17:28, Lyude Paul wrote:
>>  rust/helpers/helpers.c |  1 +
>>  rust/helpers/irq.c     | 22 ++++++++++
>>  rust/kernel/irq.rs     | 96 ++++++++++++++++++++++++++++++++++++++++++
> 
> irq is a patently bad name for this as it might get confused or conflict
> with actual interrupt related functions irq_.....
> 
> The C naming is not ideal either but it's all about the CPU local
> interrupt enable/disable, while irq_*() is related to actual interrupt
> handling and chips.
> 
> So can we please have some halfways sensible mapping to the C namings?

What do you suggest? `local_irq.rs`?

>> +/// Run the closure `cb` with interrupts disabled on the local CPU.
>> +///
>> +/// This disables interrupts, creates an [`IrqDisabled`] token and passes it to `cb`. The previous
>> +/// interrupt state will be restored once the closure completes. Note that interrupts must be
>> +/// disabled for the entire duration of `cb`, they cannot be re-enabled. In the future, this may be
>> +/// expanded on [as documented here](https://github.com/Rust-for-Linux/linux/issues/1115).
>> +///
>> +/// # Examples
>> +///
>> +/// Using [`with_irqs_disabled`] to call a function that can only be called with interrupts
>> +/// disabled:
>> +///
>> +/// ```
>> +/// use kernel::irq::{IrqDisabled, with_irqs_disabled};
>> +///
>> +/// // Requiring interrupts be disabled to call a function
>> +/// fn dont_interrupt_me(_irq: IrqDisabled<'_>) {
>> +///     // When this token is available, IRQs are known to be disabled. Actions that rely on this
>> +///     // can be safely performed
>> +/// }
>> +///
>> +/// // Disables interrupts, their previous state will be restored once the closure completes.
>> +/// with_irqs_disabled(|irq| dont_interrupt_me(irq));
>> +/// ```
>> +#[inline]
>> +pub fn with_irqs_disabled<T>(cb: impl for<'a> FnOnce(IrqDisabled<'a>) -> T) -> T {
>> +    // SAFETY: FFI call with no special requirements
>> +    let flags = unsafe { bindings::local_irq_save() };
>> +
>> +    // SAFETY: We just disabled IRQs using `local_irq_save()`
>> +    let ret = cb(unsafe { IrqDisabled::new() });
> 
> What's the point of the IrqDisabled::new() here? The above just disabled
> them, no?

Yes, the above disabled them (the functions in `bindings` are exactly
the C functions [or helper functions, if the C function is static
inline]).

The point of `IrqDisabled` is that it is a token type signifying simply
by its existence that interrupts are disabled. The `new` function is a
way to create the token without touching the current interrupt status.

Lyude mentioned that she has a use case where C calls a Rust function
with IRQ already disabled and thus we need a way to create the token in
an unchecked manner.

>> +    // Confirm that IRQs are still disabled now that the callback has finished
>> +    // SAFETY: FFI call with no special requirements
>> +    debug_assert!(unsafe { bindings::irqs_disabled() });
> 
> And here you open code the check which is in IrqDisabled::new()
> 
> So I'd rather see this as:
> 
>    token = unsafe { IrqDisabled::new() };
>    let ret = cb(token);
>    assert_valid(token);
> 
> I might misunderstand rust here, but the provided code does not make
> sense to me.

The purpose of this check is to catch any dumb implementations of the
closure `cb` passed to the function. For example

    with_irqs_disabled(|irq| {
        let guard = spin_lock_irq.lock(irq); // lock a spinlock with IRQ disabled
        unsafe { enable_irq() };
        drop(guard); // unlock it with IRQ being enabled
    });

The debug assert would catch this error.


Of course we can move the debug assert into its own function taking the
token. I think it's a good idea.

---
Cheers,
Benno


Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ