[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <9513f8d7-7f42-4c1e-bdc9-d2078d46ba1f@linaro.org>
Date: Fri, 11 Oct 2024 15:54:52 +0100
From: James Clark <james.clark@...aro.org>
To: Arnaldo Carvalho de Melo <acme@...nel.org>,
Namhyung Kim <namhyung@...nel.org>
Cc: Ingo Molnar <mingo@...nel.org>, Thomas Gleixner <tglx@...utronix.de>,
Jiri Olsa <jolsa@...nel.org>, Ian Rogers <irogers@...gle.com>,
Adrian Hunter <adrian.hunter@...el.com>,
Kan Liang <kan.liang@...ux.intel.com>, Clark Williams <williams@...hat.com>,
linux-kernel@...r.kernel.org, linux-perf-users@...r.kernel.org,
Arnaldo Carvalho de Melo <acme@...hat.com>
Subject: Re: [PATCH 2/3] perf test: Introduce '-w --list' to list the
available workloads
On 11/10/2024 3:39 pm, Arnaldo Carvalho de Melo wrote:
> From: Arnaldo Carvalho de Melo <acme@...hat.com>
>
> Using it:
>
> $ perf test -w noplop
> No workload found: noplop
> $
> $ perf test -w
> Error: switch `w' requires a value
> Usage: perf test [<options>] [{list <test-name-fragment>|[<test-name-fragments>|<test-numbers>]}]
>
> -w, --workload <work>
> workload to run for testing, use '-w --list' to list the available ones.
> $
> $ perf test -w --list
> noploop
> thloop
> leafloop
> sqrtloop
> brstack
> datasym
> landlock
> $
>
> Would be good at some point to have a description in 'struct test_workload'.
>
> Cc: Adrian Hunter <adrian.hunter@...el.com>
> Cc: Ian Rogers <irogers@...gle.com>
> Cc: Jiri Olsa <jolsa@...nel.org>
> Cc: Kan Liang <kan.liang@...ux.intel.com>
> Cc: Namhyung Kim <namhyung@...nel.org>
> Signed-off-by: Arnaldo Carvalho de Melo <acme@...hat.com>
> ---
> tools/perf/tests/builtin-test.c | 18 +++++++++++++++++-
> 1 file changed, 17 insertions(+), 1 deletion(-)
>
> diff --git a/tools/perf/tests/builtin-test.c b/tools/perf/tests/builtin-test.c
> index 2201f7ed432ce9f2..f0d10d2dd0d40019 100644
> --- a/tools/perf/tests/builtin-test.c
> +++ b/tools/perf/tests/builtin-test.c
> @@ -505,10 +505,26 @@ static int perf_test__list(int argc, const char **argv)
> return 0;
> }
>
> +static int workloads__fprintf_list(FILE *fp)
> +{
> + struct test_workload *twl;
> + int printed = 0;
> +
> + workloads__for_each(twl)
> + printed += fprintf(fp, "%s\n", twl->name);
> +
> + return printed;
> +}
> +
> static int run_workload(const char *work, int argc, const char **argv)
> {
> struct test_workload *twl;
>
> + if (!strcmp(work, "--list")) {
> + workloads__fprintf_list(stdout);
> + return 0;
> + }
> +
Very minor nit, but I think searching the workload name for an argument
instead of having a 'proper' toplevel argument seems a bit weird, but I
can see why you did it that way.
But maybe something like this might be a bit more readable especially
when searching in the usual places for an argument. And in the future
might survive auto doc attempts of known arguments:
$ perf test --list-workloads
And add it with OPT_BOOLEAN() etc.
> workloads__for_each(twl) {
> if (!strcmp(twl->name, work))
> return twl->func(argc, argv);
> @@ -544,7 +560,7 @@ int cmd_test(int argc, const char **argv)
> OPT_BOOLEAN('p', "parallel", ¶llel, "Run the tests in parallel"),
> OPT_BOOLEAN('S', "sequential", &sequential,
> "Run the tests one after another rather than in parallel"),
> - OPT_STRING('w', "workload", &workload, "work", "workload to run for testing"),
> + OPT_STRING('w', "workload", &workload, "work", "workload to run for testing, use '-w --list' to list the available ones."),
> OPT_STRING(0, "dso", &dso_to_test, "dso", "dso to test"),
> OPT_STRING(0, "objdump", &test_objdump_path, "path",
> "objdump binary to use for disassembly and annotations"),
Powered by blists - more mailing lists