[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <21d7a0d6-faac-4914-8907-1d7d983953f2@linux.alibaba.com>
Date: Wed, 16 Oct 2024 17:49:52 +0800
From: Joseph Qi <joseph.qi@...ux.alibaba.com>
To: Edward Adam Davis <eadavis@...com>
Cc: jlbec@...lplan.org, l@...enly.org, linux-kernel@...r.kernel.org,
mark@...heh.com, ocfs2-devel@...ts.linux.dev,
syzbot+81092778aac03460d6b7@...kaller.appspotmail.com,
syzkaller-bugs@...glegroups.com
Subject: Re: [PATCH V3] ocfs2: pass u64 to ocfs2_truncate_inline maybe
overflow
On 10/16/24 11:22 AM, Edward Adam Davis wrote:
> Syzbot reported a kernel BUG in ocfs2_truncate_inline.
> There are two reasons for this: first, the parameter value passed is greater
> than UINT_MAX, second, the start and end parameters of ocfs2_truncate_inline
> are "unsigned int".
>
> So, we need to add a sanity check for byte_start and byte_len right before
> ocfs2_truncate_inline() in ocfs2_remove_inode_range(), if they are greater
> than ocfs2_max_inline_data_with_xattr return -EFBIG.
>
> Reported-by: syzbot+81092778aac03460d6b7@...kaller.appspotmail.com
> Closes: https://syzkaller.appspot.com/bug?extid=81092778aac03460d6b7
> Signed-off-by: Edward Adam Davis <eadavis@...com>
> ---
> V1 -> V2: move sanity check to ocfs2_remove_inode_range
> V2 -> V3: use ocfs2_max_inline_data_with_xattr return value replace UINT_MAX
>
> fs/ocfs2/file.c | 6 ++++++
> 1 file changed, 6 insertions(+)
>
> diff --git a/fs/ocfs2/file.c b/fs/ocfs2/file.c
> index ad131a2fc58e..9327aa2f1bf4 100644
> --- a/fs/ocfs2/file.c
> +++ b/fs/ocfs2/file.c
> @@ -1784,6 +1784,12 @@ int ocfs2_remove_inode_range(struct inode *inode,
> return 0;
>
> if (OCFS2_I(inode)->ip_dyn_features & OCFS2_INLINE_DATA_FL) {
> + int max_inl = ocfs2_max_inline_data_with_xattr(inode->i_sb, di);
Or rename it to 'id_count' refer to 'struct ocfs2_inline_data'.
Better to leave a blank line here.
> + if (byte_start > max_inl || byte_start + byte_len > max_inl) {
> + ret = -EFBIG;
Seems 'EINVAL' is more proper here.
Please do corresponding change in commit log.
> + mlog_errno(ret);
> + goto out;
> + }
Better to leave a blank line.
Thanks,
Joseph
> ret = ocfs2_truncate_inline(inode, di_bh, byte_start,
> byte_start + byte_len, 0);
> if (ret) {
Powered by blists - more mailing lists