[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <ZxZpTlnhYPqg-tGh@PC2K9PVX.TheFacebook.com>
Date: Mon, 21 Oct 2024 10:46:38 -0400
From: Gregory Price <gourry@...rry.net>
To: David Hildenbrand <david@...hat.com>
Cc: x86@...nel.org, linux-kernel@...r.kernel.org,
linux-acpi@...r.kernel.org, linux-mm@...ck.org,
dan.j.williams@...el.com, ira.weiny@...el.com,
dave.hansen@...ux.intel.com, luto@...nel.org, peterz@...radead.org,
tglx@...utronix.de, mingo@...hat.com, bp@...en8.de, hpa@...or.com,
rafael@...nel.org, lenb@...nel.org, rppt@...nel.org,
akpm@...ux-foundation.org, alison.schofield@...el.com,
Jonathan.Cameron@...wei.com, rrichter@....com, ytcoode@...il.com,
haibo1.xu@...el.com, dave.jiang@...el.com
Subject: Re: [PATCH v2 2/3] x86: probe memblock size advisement value during
mm init
On Mon, Oct 21, 2024 at 01:12:26PM +0200, David Hildenbrand wrote:
>
>
> Am 16.10.24 um 21:24 schrieb Gregory Price:
> > Systems with hotplug may provide an advisement value on what the
> > memblock size should be. Probe this value when the rest of the
> > configuration values are considered.
> >
> > The new heuristic is as follows
> >
> > 1) set_memory_block_size_order value if already set (cmdline param)
> > 2) minimum block size if memory is less than large block limit
> > 3) [new] hotplug advise: lesser of advise value or memory alignment
> > 4) Max block size if system is bare-metal
> > 5) Largest size that aligns to end of memory.
> >
> > Suggested-by: David Hildenbrand <david@...hat.com>
> > Signed-off-by: Gregory Price <gourry@...rry.net>
> > ---
> > arch/x86/mm/init_64.c | 16 ++++++++++++++++
> > 1 file changed, 16 insertions(+)
> >
> > diff --git a/arch/x86/mm/init_64.c b/arch/x86/mm/init_64.c
> > index ff253648706f..b72923b12d99 100644
> > --- a/arch/x86/mm/init_64.c
> > +++ b/arch/x86/mm/init_64.c
> > @@ -1439,6 +1439,7 @@ static unsigned long probe_memory_block_size(void)
> > {
> > unsigned long boot_mem_end = max_pfn << PAGE_SHIFT;
> > unsigned long bz;
> > + int order;
> > /* If memory block size has been set, then use it */
> > bz = set_memory_block_size;
> > @@ -1451,6 +1452,21 @@ static unsigned long probe_memory_block_size(void)
> > goto done;
> > }
> > + /* Consider hotplug advisement value (if set) */
> > + order = memblock_probe_size_order();
>
> "size_order" is a very weird name. Just return a size?
>
> memory_block_advised_max_size()
>
> or sth like that?
>
There isn't technically an overall "max block size", nor any alignment
requirements - so order was a nice way of enforcing 2-order alignment
while also having the ability to get a -1/-EBUSY/whatever out.
I can change it if it's a big sticking point - but that's my reasoning.
> > + bz = order > 0 ? (1UL << order) : 0;
> > + if (bz) {
> > + /* Align down to max and up to min supported */
> > + bz = + /* Use lesser of advisement and end of memory alignment */
> > + for (; bz > MIN_MEMORY_BLOCK_SIZE; bz >>= 1) {
> > + if (IS_ALIGNED(boot_mem_end, bz))
> > + goto done;
>
> This looks like duplicate code wit the loop below.
>
> Could we refactored it into something like:
>
> advised_max_size = memory_block_advised_max_size();
> if (!advised_max_size) {
> bz = MAX_BLOCK_SIZE;
> if (!boot_cpu_has(X86_FEATURE_HYPERVISOR)
> goto done,
> } else {
> bz = max(min(advised_max_size, MAX_BLOCK_SIZE), MIN_MEMORY_BLOCK_SIZE);
> }
>
> for (; bz > MIN_MEMORY_BLOCK_SIZE; bz >>= 1) {
> if (IS_ALIGNED(boot_mem_end, bz))
> break;
>
>
this is better, will update.
>
> --
> Cheers,
>
> David / dhildenb
>
Powered by blists - more mailing lists