[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <2708af18-da90-4021-bd1b-b0491b737d6b@linux.intel.com>
Date: Mon, 21 Oct 2024 12:24:57 +0300 (EEST)
From: Ilpo Järvinen <ilpo.jarvinen@...ux.intel.com>
To: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
cc: LKML <linux-kernel@...r.kernel.org>, platform-driver-x86@...r.kernel.org,
Andy Shevchenko <andy@...nel.org>,
Mika Westerberg <mika.westerberg@...ux.intel.com>,
Hans de Goede <hdegoede@...hat.com>, Ferry Toth <fntoth@...il.com>
Subject: Re: [PATCH v2 1/3] platform/x86: intel_scu_ipc: Replace workaround
by 32-bit IO
On Mon, 21 Oct 2024, Andy Shevchenko wrote:
> The theory is that the so called workaround in pwr_reg_rdwr() is
> the actual reader of the data in 32-bit chunks. For some reason
> the 8-bit IO won't fail after that. Replace the workaround by using
> 32-bit IO explicitly and then memcpy() as much data as was requested
> by the user. The same approach is already in use in
> intel_scu_ipc_dev_command_with_size().
>
> Tested-by: Ferry Toth <fntoth@...il.com>
> Signed-off-by: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
> ---
> drivers/platform/x86/intel_scu_ipc.c | 15 ++++-----------
> 1 file changed, 4 insertions(+), 11 deletions(-)
>
> diff --git a/drivers/platform/x86/intel_scu_ipc.c b/drivers/platform/x86/intel_scu_ipc.c
> index 5b16d29c93d7..290b38627542 100644
> --- a/drivers/platform/x86/intel_scu_ipc.c
> +++ b/drivers/platform/x86/intel_scu_ipc.c
> @@ -217,12 +217,6 @@ static inline u8 ipc_read_status(struct intel_scu_ipc_dev *scu)
> return __raw_readl(scu->ipc_base + IPC_STATUS);
> }
>
> -/* Read ipc byte data */
> -static inline u8 ipc_data_readb(struct intel_scu_ipc_dev *scu, u32 offset)
> -{
> - return readb(scu->ipc_base + IPC_READ_BUFFER + offset);
> -}
> -
> /* Read ipc u32 data */
> static inline u32 ipc_data_readl(struct intel_scu_ipc_dev *scu, u32 offset)
> {
> @@ -325,11 +319,10 @@ static int pwr_reg_rdwr(struct intel_scu_ipc_dev *scu, u16 *addr, u8 *data,
> }
>
> err = intel_scu_ipc_check_status(scu);
> - if (!err && id == IPC_CMD_PCNTRL_R) { /* Read rbuf */
> - /* Workaround: values are read as 0 without memcpy_fromio */
> - memcpy_fromio(cbuf, scu->ipc_base + 0x90, 16);
> - for (nc = 0; nc < count; nc++)
> - data[nc] = ipc_data_readb(scu, nc);
> + if (!err) { /* Read rbuf */
What is the reason for the removal of that id check? This seems a clear
logic change but why? And if you remove want to remove that check, what
that comment then means?
> + for (nc = 0, offset = 0; nc < 4; nc++, offset += 4)
> + wbuf[nc] = ipc_data_readl(scu, offset);
> + memcpy(data, wbuf, count);
So do we actually need to read more than
DIV_ROUND_UP(min(count, 16U), sizeof(u32))? Because that's the approach
used in intel_scu_ipc_dev_command_with_size() which you referred to.
> }
> mutex_unlock(&ipclock);
> return err;
FYI (unrelated to this patch), there seems to be some open-coded
FIELD_PREP()s in pwr_reg_rdwr(), some of which is common code between
those if branches too.
--
i.
Powered by blists - more mailing lists